Bug 720262 - Error message about timer when using SLAC toolbar
Error message about timer when using SLAC toolbar
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: paraview (Show other bugs)
14
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-11 05:08 EDT by Kyrre Ness Sjøbæk
Modified: 2011-08-11 19:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: paraview-3.10.1-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-11 19:30:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Really small mesh (5.91 KB, application/octet-stream)
2011-08-01 09:29 EDT, Kyrre Ness Sjøbæk
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2011-07-11 05:08:59 EDT
Description of problem:
When using the SLAC toolbar (added using Menu "tools"->"manage plugins" and select SLACTools, I get the error message "Application asked to unregister timer 0x7a000017 which is not registered in this thread. Fix application." whenever pushing a button in the interface related to this toolbar.

To trigger the bug, load the toolbar, then hit the "SLAC open" button in the new toolbar. Load a mesh (I can provide one if wanted for debugging). A window then pops up with these error messages (hex address keeps changing). Messages are also written to STDERR or STDOUT (don't know which).

Version-Release number of selected component (if applicable):
paraview-3.8.1-3.fc14.x86_64

How reproducible:
Every time

Steps to Reproduce:
See above
  
Actual results:
Error messages

Expected results:
No error messages

Additional info:
I think these error messages appeared after an update a couple of months back - but it could be that I was running a statically compiled version then also - sorry for late reporting!
Comment 1 Orion Poplawski 2011-07-22 18:47:44 EDT
Any chance you can move to Fedora 15 and paraview 3.10.1 and test that?
Comment 2 Kyrre Ness Sjøbæk 2011-07-25 03:34:07 EDT
I'll try when my new laptop arrives - that will probably be installed with the newest Fedora.

Where you able to replicate the problem? The program seems to work as expected, even if these messages keeps popping up.
Comment 3 Orion Poplawski 2011-07-29 22:09:37 EDT
Can you provide a mesh?
Comment 4 Kyrre Ness Sjøbæk 2011-08-01 09:29:05 EDT
Created attachment 516136 [details]
Really small mesh
Comment 5 Orion Poplawski 2011-08-01 18:15:52 EDT
I can't reproduce with 3.10.1.  I'm thinking perhaps I'll just push 3.10.1 to F-14.
Comment 6 Kyrre Ness Sjøbæk 2011-08-02 11:24:31 EDT
Great. If you have an rpm or push it to updates-testing, I could try it out.

--- Kyrre
Comment 7 Fedora Update System 2011-08-02 11:45:49 EDT
paraview-3.10.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/paraview-3.10.1-3.fc14
Comment 8 Fedora Update System 2011-08-02 22:37:02 EDT
Package paraview-3.10.1-3.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing paraview-3.10.1-3.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/paraview-3.10.1-3.fc14
then log in and leave karma (feedback).
Comment 9 Kyrre Ness Sjøbæk 2011-08-03 07:31:16 EDT
Tested the update, seems to work fine, and the bug is gone. Great job! Only negative comment is that I had to re-add the SLAC toolbar after updating. I added the same comment at fedoraproject.org, leaving some karma :)
Comment 10 Fedora Update System 2011-08-11 19:29:59 EDT
paraview-3.10.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.