Bug 720318 - [RFE] add function acl_extended_file_nofollow()
[RFE] add function acl_extended_file_nofollow()
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: acl (Show other bugs)
6.1
All Linux
medium Severity high
: rc
: ---
Assigned To: Kamil Dudka
Ondrej Moriš
: FutureFeature, Patch
Depends On: 692982
Blocks: 692823 719607 720325 733978 733979
  Show dependency treegraph
 
Reported: 2011-07-11 07:39 EDT by Ian Kent
Modified: 2011-12-06 11:37 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 692982
: 733978 (view as bug list)
Environment:
Last Closed: 2011-12-06 11:37:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 RHEL Product and Program Management 2011-07-11 07:58:12 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 9 Ondrej Moriš 2011-08-16 19:16:27 EDT
Kamil, could you propose some reproducer for this RFE? I am using strace to get acl of a link target, but there is no difference between old and new version. I am sure, that there is a more reliable way to trigger this new function call. Is it?
Comment 10 Kamil Dudka 2011-08-17 01:09:42 EDT
Ondrej, what are you stracing actually?  ls -l?  Then you need to use a new enough version of coreutils (as for RHEL-6, it means coreutils-8.4-14.el6 or newer).  Some hints for testing are also in Bodhi since we have already successfully tested the same change in the Fedora acl package:

https://admin.fedoraproject.org/updates/acl-2.2.49-9.fc14
Comment 11 Kamil Dudka 2011-08-17 01:18:40 EDT
Actually, the coreutils-8.4-14.el6 is not new enough as it was built against an old version of libacl.  We will need to rebuild coreutils against libacl-devel >= 2.2.49-6:

checking for acl_extended_file... yes
checking for acl_extended_file_nofollow... no

If you need to test the acl package now, please use coreutils from Fedora 16, rawhide, or upstream.
Comment 15 errata-xmlrpc 2011-12-06 11:37:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1657.html

Note You need to log in before you can comment on or make changes to this bug.