Bug 72039 - limbo: no recognition of the onboard-graficcard on an msi-k7n420 pro
limbo: no recognition of the onboard-graficcard on an msi-k7n420 pro
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 16:40 EDT by shrek-m
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 12:17:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2002-08-20 16:40:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
nor rhl 7.x nor limbo
the onboard graficcard will not be recognized on an msi-k7n420 pro mainboard,the
installation hangs (no driver for nvidia geforce 2 mx)
boot:linux text

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot from floppy
2.boot:linux
3.starting X-server ....????
	

Actual Results:  installation hangs

Expected Results:  kill x-server,installation in text-mode

Additional info:

NVIDIA_GLX, NVIDIA_kernel at www.nvidia.com
Comment 1 Michael Fulbright 2002-08-22 12:17:02 EDT
Any ideas Mike?
Comment 2 Mike A. Harris 2002-08-22 12:45:25 EDT
Yes, I've got an idea....

shrek-m)  You've filed at least 3 bugs about this in less than 2 days,
all of which you've been told that the Nvidia binary only driver is
not supported.

Not supported _at_ _all_.  That means, in no way, is it supported, which
means that it isn't supported.  That means that it does not work, because
we do not support it.

We support the "nv" driver _ONLY_.  That goes for XFree86, Xconfigurator,
redhat-config-xfree86, xf86config, xf86cfg, anaconda (the installer),
the kernel, and everything else.

Only the "nv" driver is supported, and the support for your card, is only
available using the "nv" driver.  All other drivers not supplied by
Red Hat...  are unsupported.  Roughly translated, that means we
do not support them.

If you DO use the Nvidia driver, instead of the "nv" driver, then
when you upgrade, your X configuration will NOT be touched.  This
is intentional, because we do not modify a users configuration if
they're using unsupported drivers, of which the "nvidia" driver
is.

Solution:  Uninstall the Nvidia drivers completely, remove the
Nvidia GLX, and kernel stuff.  Reinstall XFree86 to put back
the files that were destroyed by the Nvidia driver installation
(libGL I believe).  Edit your X config, and put the "nv" driver
back.

Run X configuration utilities, and it should work.

As an additional note, please keep in mind that the "nvidia" binary
only drivers are unsupported in all releases of Red Hat Linux,
and that using them makes your whole system unsupported unless
you can reproduce a problem using only the "nv" driver.

Closing bug as NOTABUG.
Comment 3 shrek-m 2002-08-24 06:38:49 EDT
thanks for your reply,

but THE "NV"-DRIVER DOESN4T WORK for me.
neither anaconda, nor any other X-Configuration-tool could bring the X-server up.
all in all several days since rhl 7.2  :-(
(i do prefer rhl 6.2 on i486)

for me, the easyest way is to install NVIDIA_kernel and NVIDIA_GLX
(tar, cd, no configure!, make, make install)
and edit the XF86Config by myself to
DRIVER "nvidia"

all about in a few minutes :-)

everytime i am running a X-configuration-tool the entry is changed to
DRIVER "nv"
and i get an error starting X with crash

it4s always the same in rhl 7.2/7.3/7.393

for me its better to have a running unsupported system than ...

bye
quit
an exit!


Note You need to log in before you can comment on or make changes to this bug.