Bug 720520 - rubygem-yard causes warning in gem about missing method overwrite_accessor
Summary: rubygem-yard causes warning in gem about missing method overwrite_accessor
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-yard
Version: 15
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Mo Morsi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-11 22:42 UTC by Deron Meranda
Modified: 2011-08-11 23:33 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-08-11 23:33:21 UTC


Attachments (Terms of Use)

Description Deron Meranda 2011-07-11 22:42:27 UTC
Description of problem:

When using the ruby 'gem' program it emits a warning message apparently caused by a bug in rubygem-yard:

$ gem -v
Error loading RubyGems plugin
"/usr/lib/ruby/gems/1.8/gems/yard-0.5.3/lib/rubygems_plugin.rb":
undefined method `overwrite_accessor' for Gem::Specification:Class
(NoMethodError)
1.7.2

Version-Release number of selected component (if applicable):

ruby-1.8.7.334-1.fc15.x86_64
rubygems-1.7.2-2.fc15.noarch
rubygem-yard-0.5.3-3.fc14.noarch

Note that as of this time, rubygem-yard is still on the Fedora 14 version, whereas the rest of Ruby is on Fedora 15.

Also rubygem-yard is a required dependency on rubygem-haml, which is on an F15 version.

How reproducible:

Always.

Steps to Reproduce:
1. Enter any '/usr/bin/gem' command, such as 'gem -v'
  
Actual results:
Error loading RubyGems plugin
"/usr/lib/ruby/gems/1.8/gems/yard-0.5.3/lib/rubygems_plugin.rb":
undefined method `overwrite_accessor' for Gem::Specification:Class
(NoMethodError)

Expected results:
No warning message

Additional info:

Comment 2 Mamoru TASAKA 2011-07-25 00:55:35 UTC
ping?

Comment 3 Mo Morsi 2011-07-25 21:03:20 UTC
I updated yard to 0.7.2 in rawhide. Tried to backport the patch against the version in F15 but am having trouble building yard there due to various issues 

Feel free to grab the updated rpm from rawhide while I continue figuring this out.

Comment 4 Fedora Update System 2011-08-01 23:06:29 UTC
rubygem-yard-0.5.3-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rubygem-yard-0.5.3-4.fc15

Comment 5 Fedora Update System 2011-08-03 02:32:21 UTC
Package rubygem-yard-0.5.3-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-yard-0.5.3-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/rubygem-yard-0.5.3-4.fc15
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-08-11 23:33:16 UTC
rubygem-yard-0.5.3-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.