Bug 720594 - rt2800pci: Add device ID for RT539F device
rt2800pci: Add device ID for RT539F device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
: Reopened
: 770332 770474 770987 772393 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-12 03:59 EDT by Kim Bisgaard
Modified: 2012-01-09 14:07 EST (History)
15 users (show)

See Also:
Fixed In Version: kernel-3.1.7-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-07 18:05:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kim Bisgaard 2011-07-12 03:59:03 EDT
Description of problem:
The wireless chip in the notebook dm1-3100 from HP is a RT539f aka RT5390

Version-Release number of selected component (if applicable):
2.6.38.8-32.fc15.i686

Additional info:

Debian fixed this like this:
Subject: [PATCH v2] rt2x00: Add device ID for RT539F device.
2 	From: Gertjan van Wingerde <gwingerde@gmail.com>
3 	Date: Sat, 04 Jun 2011 15:55:00 -0500
4 	
5 	Reported-by: Wim Vander Schelden <wim@fixnum.org>
6 	Signed-off-by: Gertjan van Wingerde <gwingerde@gmail.com>
7 	---
8 	drivers/net/wireless/rt2x00/rt2800pci.c | 1 +
9 	1 files changed, 1 insertions(+), 0 deletions(-)
10 	
11 	diff --git a/drivers/net/wireless/rt2x00/rt2800pci.c b/drivers/net/wireless/rt2x00/rt2800pci.c
12 	index 5513edf..fd99449 100644
13 	--- a/drivers/net/wireless/rt2x00/rt2800pci.c
14 	+++ b/drivers/net/wireless/rt2x00/rt2800pci.c
15 	@@ -1160,6 +1160,7 @@ static DEFINE_PCI_DEVICE_TABLE(rt2800pci_device_table) = {
16 	#endif
17 	#ifdef CONFIG_RT2800PCI_RT53XX
18 	{ PCI_DEVICE(0x1814, 0x5390) },
19 	+ { PCI_DEVICE(0x1814, 0x539f) },
20 	#endif
21 	{ 0, }
22 	};
23 	--
24 	1.7.5
25
Comment 1 John W. Linville 2011-07-12 15:07:02 EDT
I have added that patch to Rawhide.  Unfortunately, it depends on other bits that are not present in the F15 kernels.
Comment 2 Kim Bisgaard 2011-07-31 04:18:31 EDT
It would be prudent to add that patch to the f15 update kernel 2.6.40 (aka 3.0) that davej is building
Comment 3 Kim Bisgaard 2011-08-03 04:25:32 EDT
The 2.6.40 kernel is now pushed into f15.

I have confirmed that the "bug" is present there, and thus this has to be reopened.
Comment 4 Josh Boyer 2011-08-03 08:07:09 EDT
I'll get this pulled into 2.6.40 today.
Comment 5 Fedora Update System 2011-08-16 08:46:59 EDT
kernel-2.6.40.3-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
Comment 6 Fedora Update System 2011-08-16 21:17:33 EDT
Package kernel-2.6.40.3-0.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.40.3-0.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-08-17 22:29:54 EDT
kernel-2.6.40.3-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Kim Bisgaard 2011-12-24 07:47:17 EST
Sorry to reopen this, but kernel-3.1.6-1.fc16 has forgotten this pci-id again.
Comment 9 David Dreggors 2011-12-30 00:40:01 EST
I can confirm that kernel '3.1.6-1.fc16.x86_64' has "forgotten" this pci-id as can the others in Bug #770474.

My device shows pci-id 1814:5390:

03:00.0 Network controller [0280]: Ralink corp. Device [1814:5390]

It works under kernels '3.1.5-6.fc16.x86_64' and '3.1.5-2.fc16.x86_64' but is not detected by rt2800pci under kernel '3.1.6-1.fc16.x86_64'
Comment 10 Vinay S Shastry 2011-12-31 00:05:55 EST
Another strange thing that might be related is that there's no sources for rt2800 modules in kernel-devel-3.1.6-1.fc16.x86_64.
Comment 11 David Dreggors 2012-01-01 03:08:22 EST
It's rt2800pci (not rt2800) and the source is not fully provided by kernel-devel package. You would need to follow the steps at:
http://fedoraproject.org/wiki/Building_a_custom_kernel

to see the actual c source code for the rt2800pci (rt2800pci.c) driver.
Comment 12 Vinay S Shastry 2012-01-01 04:06:19 EST
(In reply to comment #11)
> It's rt2800pci (not rt2800) and the source is not fully provided by
> kernel-devel package. You would need to follow the steps at:
> http://fedoraproject.org/wiki/Building_a_custom_kernel
> 
> to see the actual c source code for the rt2800pci (rt2800pci.c) driver.

Sorry. I meant headers, not sources.

---

14:34:35 %] find /usr/src/kernels/3.1.6-1.fc16.x86_64 | grep rt2800   [kernels]
zsh: done       find /usr/src/kernels/3.1.6-1.fc16.x86_64 | 
zsh: exit 1     grep --colour=auto rt2800

14:34:48 %] find /usr/src/kernels/3.1.5-6.fc16.x86_64 | grep rt2800   [kernels]
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800pci.h
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800usb
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800usb/rt35xx.h
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800usb/rt53xx.h
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800usb/rt33xx.h
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800usb/unknown.h
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800usb.h
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800pci
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800pci/rt35xx.h
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800pci/rt53xx.h
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800pci/rt33xx.h
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800/lib.h
Comment 13 David Dreggors 2012-01-02 02:19:22 EST
Thanks for the clarificaion Vinay.
Yes, that is different then, I see what you mean. I also see the same results:


[root@mobile-tek ~ ]# find /usr/src/kernels/ -name 'rt2800pci.h'
/usr/src/kernels/3.1.5-6.fc16.x86_64/include/config/rt2800pci.h
/usr/src/kernels/3.1.5-2.fc16.x86_64/include/config/rt2800pci.h


[root@mobile-tek ~ ]# rpm -qa |grep kernel
kernel-devel-3.1.5-6.fc16.x86_64
kernel-devel-3.1.6-1.fc16.x86_64
kernel-headers-3.1.6-1.fc16.x86_64
kernel-devel-3.1.5-2.fc16.x86_64
libreport-plugin-kerneloops-2.0.8-3.fc16.x86_64
abrt-addon-kerneloops-2.0.7-2.fc16.x86_64
kernel-3.1.5-6.fc16.x86_64
kernel-3.1.6-1.fc16.x86_64
kernel-3.1.5-2.fc16.x86_64


As you can see I have the kernel-devel packages installed for all of my kernels and yet the find command only locates the headers for the previous kernels. 

Something is wrong there as Vinay has pointed out.
Comment 14 Josh Boyer 2012-01-03 08:52:23 EST
*** Bug 770474 has been marked as a duplicate of this bug. ***
Comment 15 Josh Boyer 2012-01-03 09:05:59 EST
The upstream commit that adds the device ID is 71e0b38c2914018b01f3f08b43ee9e3328197699 and that is included in the final 3.1 release.  It's also included in the 3.1.6 stable tree.

The compat-wireless stuff was enabled in the 3.1.6 update.  Looking in the build logs, I see errors like this:

LD [M]  /builddir/build/BUILD/kernel-3.1.fc16/compat-wireless-3.2-rc6-3/drivers/net/wireless/rt2x00/rt2800pci.ko
FATAL: Could not load /lib/modules/2.6.32-220.el6.x86_64/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.32-220.el6.x86_64/modules.dep: No such file or directory

which makes me wonder if that module is not getting added to modules.dep and won't autoload.
Comment 16 Vincent Minder 2012-01-03 09:24:21 EST
While headers are also missing on my system, "locate rt2800pci" actually
returns a file under a "backports" subfolder of the modules hierarchy:

[root@hp-dm1 ~]$ locate rt2800pci
/lib/modules/3.1.6-1.fc16.i686/backports/drivers/net/wireless/rt2x00/rt2800pci.ko

Also, the release notes for kernel 3.6.1-1 mention this:

* Wed Dec 21 2011 John W. Linville <linville at redhat.com> 
- Revise compat-wireless configuration
- Enable with-backports by default
- Update compat-wireless snaptshot from verstion 3.2-rc6-3

http://lists.fedoraproject.org/pipermail/package-announce/2011-December/071332.html

Could this be related to the problem?
Comment 17 John W. Linville 2012-01-03 10:15:42 EST
I think those "FATAL:..." message from compat-wireless, while disturbing, are
just SPAM.  I'll see if I can silence them.

The actual problem here is that the compat-wireless config didn't enable the
option for the PCI IDs of interest here.  I just checked-in a change for that
in both f16 and rawhide.
Comment 18 Josh Boyer 2012-01-03 16:01:12 EST
*** Bug 770987 has been marked as a duplicate of this bug. ***
Comment 19 Fedora Update System 2012-01-03 17:53:34 EST
kernel-3.1.7-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.1.7-1.fc16
Comment 20 David Dreggors 2012-01-04 08:26:45 EST
I downloaded and installed the kernel and kernel-devel/kernel-headers packages and tested. I can confirm the fix on my setup. I have reviewed my logs after several boots to the new kernel and I see no errors or issues that were not already there in the 3.1.5/3.1.6 kernels either so it looks good.

I only installed for testing, I will uninstall now and wait for the kernel to be in the repos :)
Comment 21 John W. Linville 2012-01-04 09:38:29 EST
*** Bug 770332 has been marked as a duplicate of this bug. ***
Comment 22 Fedora Update System 2012-01-05 16:06:10 EST
Package kernel-3.1.7-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.1.7-1.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0145/kernel-3.1.7-1.fc16
then log in and leave karma (feedback).
Comment 23 David Dreggors 2012-01-05 20:26:42 EST
karma added and that brought it enough to be pushed to stable updates repo!
Comment 24 Fedora Update System 2012-01-07 18:05:26 EST
kernel-3.1.7-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 lionghostshop 2012-01-08 04:04:10 EST
it works now
Comment 26 Josh Boyer 2012-01-08 10:05:44 EST
*** Bug 772393 has been marked as a duplicate of this bug. ***
Comment 27 walt 2012-01-09 14:07:10 EST
New kernel-6.1.7-1 fixed the wlan bug.

Note You need to log in before you can comment on or make changes to this bug.