Bug 72063 - too many dependencies for php-4.1.2-7.2.3
too many dependencies for php-4.1.2-7.2.3
Status: CLOSED DUPLICATE of bug 72007
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 19:01 EDT by Florin Andrei
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 19:01:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2002-08-20 19:01:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
When upgrading a RH 7.2 to the latest php-4.1.2-7.2.3, i got an insane list of
dependencies:

[root@zoul work]# ls
apache-1.3.22-6.i386.rpm         php-4.1.2-7.2.3.i386.rpm
apache-manual-1.3.22-6.i386.rpm  php-mysql-4.1.2-7.2.3.i386.rpm
mod_ssl-2.8.5-6.i386.rpm
[root@zoul work]# rpm -Uvh *
error: failed dependencies:
	bzip2-devel >= 1.0 is needed by php-4.1.2-7.2.3
	curl-devel >= 7.8 is needed by php-4.1.2-7.2.3
	db3-devel is needed by php-4.1.2-7.2.3
	expat-devel is needed by php-4.1.2-7.2.3
	freetype-devel >= 2.0.0 is needed by php-4.1.2-7.2.3
	gd-devel is needed by php-4.1.2-7.2.3
	gdbm-devel is needed by php-4.1.2-7.2.3
	gmp-devel is needed by php-4.1.2-7.2.3
	imap >= 2000-9 is needed by php-4.1.2-7.2.3
	imap-devel >= 2000-9 is needed by php-4.1.2-7.2.3
	krb5-devel is needed by php-4.1.2-7.2.3
	libjpeg-devel is needed by php-4.1.2-7.2.3
	libpng-devel is needed by php-4.1.2-7.2.3
	libstdc++-devel is needed by php-4.1.2-7.2.3
	libxml2-devel >= 2.4 is needed by php-4.1.2-7.2.3
	mm-devel is needed by php-4.1.2-7.2.3
	ncurses-devel is needed by php-4.1.2-7.2.3
	openssl-devel is needed by php-4.1.2-7.2.3
	pam-devel is needed by php-4.1.2-7.2.3
	postgresql is needed by php-4.1.2-7.2.3
	postgresql-devel is needed by php-4.1.2-7.2.3
	pspell-devel is needed by php-4.1.2-7.2.3
	ucd-snmp is needed by php-4.1.2-7.2.3
	ucd-snmp-utils is needed by php-4.1.2-7.2.3
	ucd-snmp-devel is needed by php-4.1.2-7.2.3
	unixODBC is needed by php-4.1.2-7.2.3
	unixODBC-devel is needed by php-4.1.2-7.2.3
[root@zoul work]# rpm -qa | grep apache
apache-manual-1.3.22-2
apache-1.3.22-2
[root@zoul work]# rpm -qa | grep mod_ssl
mod_ssl-2.8.5-4
[root@zoul work]# rpm -qa | grep php    
php-mysql-4.0.6-15
php-4.0.6-15
[root@zoul work]#


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.upgrade to php-4.1.2-7.2.3
2.
3.
	

Actual Results:  got lots of dependencies (see above)

Expected Results:  upgrade should not require so many new packages

Additional info:
Comment 1 Phil Copeland 2002-08-20 19:13:18 EDT
Working on an errata or the errata.. workarounds at #72007

Phil
=--=

*** This bug has been marked as a duplicate of 72007 ***

Note You need to log in before you can comment on or make changes to this bug.