Bug 720644 - [PATCH] large string repeat count causes heap corruption
[PATCH] large string repeat count causes heap corruption
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Petr Pisar
Martin Kyral
: Patch
: 720652 (view as bug list)
Depends On:
Blocks: 836160 840699
  Show dependency treegraph
 
Reported: 2011-07-12 07:16 EDT by Petr Pisar
Modified: 2013-02-21 05:43 EST (History)
6 users (show)

See Also:
Fixed In Version: perl-5.10.1-129.el6
Doc Type: Bug Fix
Doc Text:
Cause: Repeating string with `x' operator more than 2^31 times (e.g. "my $s = 'a' x (2**31+1);"). Consequence: Computed string becomes corrupted or the interpreter crashes. Fix: The right site of `x' operator has been limited to 2^31 to prevent from wrapping internal representation of the count. Result: It's not possible to repeat string more than 2^31 times and thus corrupt memory or crash the interpreter. If user supplies bigger count, the interpreter will raise an exception.
Story Points: ---
Clone Of: 720610
Environment:
Last Closed: 2013-02-21 05:43:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix refusing big numbers (1.07 KB, patch)
2012-10-12 04:28 EDT, Petr Pisar
no flags Details | Diff
Fix case of 2^32±1 repeat counter. (905 bytes, patch)
2012-12-04 11:36 EST, Petr Pisar
no flags Details | Diff

  None (edit)
Description Petr Pisar 2011-07-12 07:16:27 EDT
+++ This bug was initially created as a clone of Bug #720610 +++

Created attachment 512377 [details]
proposed patch

Description of problem: string repeat count > 2^31 causes heap corruption

Version-Release number of selected component (if applicable):
perl-5.12.4-159.fc15.x86_64

How reproducible: every time

Steps to Reproduce:
1. perl -le 'print "v"x(2**31+1)'
2.
3.
  
Actual results:
segfault

Expected results:
2^31+1 'v's followed by a newline on output

Additional info:
    http://thread.gmane.org/gmane.comp.lang.perl.perl5.porters/96812
    https://rt.perl.org/rt3/Ticket/Display.html?id=94560

Patch attached.

----
RHEL-6 (perl-5.10.1-119.el6.x86_64) affected. I could not achieve segfault but invalid characters were printed.
Comment 2 RHEL Product and Program Management 2011-07-12 07:38:35 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Petr Pisar 2011-07-12 08:46:12 EDT
*** Bug 720652 has been marked as a duplicate of this bug. ***
Comment 6 Petr Pisar 2012-10-12 04:09:43 EDT
The patch changes API. I will use different approach proposed in bug #862413. That means interpreter will abort instead of accepting so large numbers.
Comment 7 Petr Pisar 2012-10-12 04:28:00 EDT
Created attachment 625851 [details]
Fix refusing big numbers
Comment 13 Petr Pisar 2012-12-04 11:15:01 EST
The fix (In reply to comment #7)
> Created attachment 625851 [details]
> Fix refusing big numbers

This is not sufficient on i686 because value there an explicit check before that wraps count number to IV_MAX which is 2 less than I32_MAX (for unknown reason), pp.c:1493:

  if (uv > IV_MAX)
    count = IV_MAX; /* The best we can do? */

We need to croak here too, otherwise all requiest bigger than 2^32-2 gets wrapped to this value and then not all bytes get initialized properly.
Comment 14 Petr Pisar 2012-12-04 11:36:06 EST
Created attachment 657636 [details]
Fix case of 2^32±1 repeat counter.

This patch is needed on i686 to prevent silent data corruption.
Comment 20 errata-xmlrpc 2013-02-21 05:43:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0444.html

Note You need to log in before you can comment on or make changes to this bug.