Bug 720771 - HFSPlus DVD will not mount post install
HFSPlus DVD will not mount post install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Josh Boyer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-12 13:52 EDT by Xtian Simon
Modified: 2011-09-26 15:42 EDT (History)
8 users (show)

See Also:
Fixed In Version: kernel-3.0.1-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-26 15:42:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Xtian Simon 2011-07-12 13:52:27 EDT
Description of problem:
A data DVD burned in OSX 10.4 DiskUtility as HFSPlus will not mount to a fresh install of Fedora 15

Version-Release number of selected component (if applicable):
Name        : util-linux
Arch        : i686
Version     : 2.19.1
Release     : 1.3.fc15
(This is the most recent version available via YUM)

Name        : hfsplus-tools
Arch        : i686
Version     : 332.14
Release     : 12.fc15
(This is the most recent version available via YUM)


How reproducible:
The problem media was produced on the same machine/application/DVD-R used to make the Fedora ISO [url="http://download.fedoraproject.org/pub/fedora/linux/releases/15/Fedora/i386/iso/Fedora-15-i386-DVD.iso"] install dvd: Mac OSX 10.4 DiskUtility app.

The troubled data disk is type=HFSPlus. It mounts on the Mac. It mounted on the PC when F11 was installed.

I have further tested the F15 install with supplemental DVDs from programming books. These automount.

Steps to Reproduce:
typing the commands as root:
1. #mount /dev/dvd /media
OR
2. #mount /dev/cdrom /media
OR
3. #mkdir /media/dvd
#mount /dev/dvd /media/dvd

>>Actual results:
mount: block device /dev/sr0 is write-protected, mounting read-only
mount: you must specify the filesystem type

4. # mount -t hfsplus /dev/dvd /media

>>Actual results:
mount: block device /dev/sr0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sr0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


Expected results:
Mount of the DVD media

Additional info:
5.# dmesg | tail 
> Produces:
[ 3320.206086] sr 1:0:0:0: [sr0] unaligned transfer
[ 3320.206140] hfs: unable to find HFS+ superblock
[ 3394.307359] EXT3-fs (sr0): error: can't find ext3 filesystem on dev sr0.
[ 3394.315300] EXT2-fs (sr0): error: can't find an ext2 filesystem on dev sr0.
[ 3394.392094] ISOFS: Unable to identify CD-ROM format.
[ 3394.460540] FAT: bogus number of reserved sectors
[ 3394.460554] VFS: Can't find a valid FAT filesystem on dev sr0.
[ 3394.525307] hfs: can't find a HFS filesystem on dev sr0.
[ 3394.535067] sr 1:0:0:0: [sr0] unaligned transfer
[ 3394.535109] hfs: unable to find HFS+ superblock


6. /dev ls -al
drwxr-xr-x  19 root  root        3820 Jul 12 13:39 .
dr-xr-xr-x. 23 root  root        4096 Jul 12 13:38 ..
crw-rw----   1 root  video    10, 175 Jul 12 13:36 agpgart
crw-------   1 root  root     10, 235 Jul 12 13:36 autofs
drwxr-xr-x   2 root  root         700 Jul 12 13:36 block
drwxr-xr-x   2 root  root          80 Jul 12 13:36 bsg
crw-------   1 root  root     10, 234 Jul 12 13:36 btrfs-control
drwxr-xr-x   3 root  root          60 Jul 12 13:36 bus
lrwxrwxrwx   1 root  root           3 Jul 12 13:36 cdrom -> sr0
lrwxrwxrwx   1 root  root           3 Jul 12 13:36 cdrw -> sr0
drwxr-xr-x   2 root  root        3160 Jul 12 13:39 char
crw-------   1 root  root      5,   1 Jul 12 13:38 console
lrwxrwxrwx   1 root  root          11 Jul 12 13:36 core -> /proc/kcore
drwxr-xr-x   3 root  root          80 Jul 12 13:36 cpu
crw-------   1 root  root     10,  62 Jul 12 13:36 cpu_dma_latency
drwxr-xr-x   5 root  root         100 Jul 12 13:36 disk
brw-rw----   1 root  disk    253,   0 Jul 12 13:36 dm-0
brw-rw----   1 root  disk    253,   1 Jul 12 13:36 dm-1
brw-rw----   1 root  disk    253,   2 Jul 12 13:36 dm-2
brw-rw----   1 root  disk    253,   3 Jul 12 13:36 dm-3
drwxr-xr-x   2 root  root          80 Jul 12 13:36 dri
lrwxrwxrwx   1 root  root           3 Jul 12 13:36 dvd -> sr0
lrwxrwxrwx   1 root  root           3 Jul 12 13:36 fb -> fb0
crw-rw----   1 root  video    29,   0 Jul 12 13:36 fb0
lrwxrwxrwx   1 root  root          13 Jul 12 13:36 fd -> /proc/self/fd
crw-rw-rw-   1 root  root      1,   7 Jul 12 13:36 full
crw-rw-rw-   1 root  root     10, 229 Jul 12 13:36 fuse
crw-------   1 root  root    250,   0 Jul 12 13:36 fw0
crw-------   1 root  root     10, 228 Jul 12 13:36 hpet
drwxr-xr-x   2 root  root           0 Jul 12 13:36 hugepages
prw-------   1 root  root           0 Jul 12 13:36 initctl
drwxr-xr-x   3 root  root         280 Jul 12 13:36 input
crw-------   1 root  root      1,  11 Jul 12 13:36 kmsg
srw-rw-rw-   1 root  root           0 Jul 12 13:36 log
brw-rw----   1 root  disk      7,   0 Jul 12 13:36 loop0
brw-rw----   1 root  disk      7,   1 Jul 12 13:36 loop1
brw-rw----   1 root  disk      7,   2 Jul 12 13:36 loop2
brw-rw----   1 root  disk      7,   3 Jul 12 13:36 loop3
brw-rw----   1 root  disk      7,   4 Jul 12 13:36 loop4
brw-rw----   1 root  disk      7,   5 Jul 12 13:36 loop5
brw-rw----   1 root  disk      7,   6 Jul 12 13:36 loop6
brw-rw----   1 root  disk      7,   7 Jul 12 13:36 loop7
lrwxrwxrwx   1 root  root          13 Jul 12 13:36 MAKEDEV -> /sbin/MAKEDEV
drwxr-xr-x   2 root  root         140 Jul 12 13:36 mapper
crw-------   1 root  root     10, 227 Jul 12 13:36 mcelog
crw-r-----   1 root  kmem      1,   1 Jul 12 13:36 mem
drwxr-xr-x   2 root  root           0 Jul 12 13:36 mqueue
drwxr-xr-x   2 root  root          60 Jul 12 13:36 net
crw-------   1 root  root     10,  61 Jul 12 13:36 network_latency
crw-------   1 root  root     10,  60 Jul 12 13:36 network_throughput
crw-rw-rw-   1 root  root      1,   3 Jul 12 13:36 null
crw-r-----   1 root  kmem     10, 144 Jul 12 13:36 nvram
crw-------   1 root  root      1,  12 Jul 12 13:36 oldmem
crw-rw----   1 root  lp       99,   0 Jul 12 13:36 parport0
crw-r-----   1 root  kmem      1,   4 Jul 12 13:36 port
crw-------   1 root  root    108,   0 Jul 12 13:36 ppp
crw-rw-rw-   1 root  tty       5,   2 Jul 12 14:34 ptmx
drwxr-xr-x   2 root  root           0 Jul 12 13:36 pts
brw-rw----   1 root  disk      1,   0 Jul 12 13:36 ram0
brw-rw----   1 root  disk      1,   1 Jul 12 13:36 ram1
brw-rw----   1 root  disk      1,  10 Jul 12 13:36 ram10
brw-rw----   1 root  disk      1,  11 Jul 12 13:36 ram11
brw-rw----   1 root  disk      1,  12 Jul 12 13:36 ram12
brw-rw----   1 root  disk      1,  13 Jul 12 13:36 ram13
brw-rw----   1 root  disk      1,  14 Jul 12 13:36 ram14
brw-rw----   1 root  disk      1,  15 Jul 12 13:36 ram15
brw-rw----   1 root  disk      1,   2 Jul 12 13:36 ram2
brw-rw----   1 root  disk      1,   3 Jul 12 13:36 ram3
brw-rw----   1 root  disk      1,   4 Jul 12 13:36 ram4
brw-rw----   1 root  disk      1,   5 Jul 12 13:36 ram5
brw-rw----   1 root  disk      1,   6 Jul 12 13:36 ram6
brw-rw----   1 root  disk      1,   7 Jul 12 13:36 ram7
brw-rw----   1 root  disk      1,   8 Jul 12 13:36 ram8
brw-rw----   1 root  disk      1,   9 Jul 12 13:36 ram9
crw-rw-rw-   1 root  root      1,   8 Jul 12 13:36 random
drwxr-xr-x   2 root  root          60 Jul 12 13:36 raw
crw-r--r--+  1 root  root     10,  59 Jul 12 13:36 rfkill
lrwxrwxrwx   1 root  root           4 Jul 12 13:36 root -> dm-3
lrwxrwxrwx   1 root  root           4 Jul 12 13:36 rtc -> rtc0
crw-------   1 root  root    254,   0 Jul 12 13:36 rtc0
lrwxrwxrwx   1 root  root           3 Jul 12 13:36 scd0 -> sr0
brw-rw----   1 root  disk      8,   0 Jul 12 13:36 sda
brw-rw----   1 root  disk      8,   1 Jul 12 13:36 sda1
brw-rw----   1 root  disk      8,   2 Jul 12 13:36 sda2
brw-rw----   1 root  disk      8,   3 Jul 12 13:36 sda3
crw-rw----   1 root  disk     21,   0 Jul 12 13:36 sg0
crw-rw----+  1 root  cdrom    21,   1 Jul 12 13:36 sg1
drwxrwxrwt   2 root  root          80 Jul 12 13:40 shm
crw-------   1 root  root     10, 231 Jul 12 13:36 snapshot
drwxr-xr-x   3 root  root         320 Jul 12 13:36 snd
brw-rw----+  1 root  cdrom    11,   0 Jul 12 13:36 sr0
lrwxrwxrwx   1 root  root          15 Jul 12 13:36 stderr -> /proc/self/fd/2
lrwxrwxrwx   1 root  root          15 Jul 12 13:36 stdin -> /proc/self/fd/0
lrwxrwxrwx   1 root  root          15 Jul 12 13:36 stdout -> /proc/self/fd/1
lrwxrwxrwx   1 root  root           4 Jul 12 13:36 systty -> tty0
crw-rw-rw-   1 root  tty       5,   0 Jul 12 13:53 tty
crw--w----   1 root  tty       4,   0 Jul 12 13:36 tty0
crw--w----   1 Xtian tty       4,   1 Jul 12 13:40 tty1
crw--w----   1 root  tty       4,  10 Jul 12 13:36 tty10
crw--w----   1 root  tty       4,  11 Jul 12 13:36 tty11
crw--w----   1 root  tty       4,  12 Jul 12 13:36 tty12
crw--w----   1 root  tty       4,  13 Jul 12 13:36 tty13
crw--w----   1 root  tty       4,  14 Jul 12 13:36 tty14
crw--w----   1 root  tty       4,  15 Jul 12 13:36 tty15
crw--w----   1 root  tty       4,  16 Jul 12 13:36 tty16
crw--w----   1 root  tty       4,  17 Jul 12 13:36 tty17
crw--w----   1 root  tty       4,  18 Jul 12 13:36 tty18
crw--w----   1 root  tty       4,  19 Jul 12 13:36 tty19
crw-------   1 root  root      4,   2 Jul 12 13:38 tty2
crw--w----   1 root  tty       4,  20 Jul 12 13:36 tty20
crw--w----   1 root  tty       4,  21 Jul 12 13:36 tty21
crw--w----   1 root  tty       4,  22 Jul 12 13:36 tty22
crw--w----   1 root  tty       4,  23 Jul 12 13:36 tty23
crw--w----   1 root  tty       4,  24 Jul 12 13:36 tty24
crw--w----   1 root  tty       4,  25 Jul 12 13:36 tty25
crw--w----   1 root  tty       4,  26 Jul 12 13:36 tty26
crw--w----   1 root  tty       4,  27 Jul 12 13:36 tty27
crw--w----   1 root  tty       4,  28 Jul 12 13:36 tty28
crw--w----   1 root  tty       4,  29 Jul 12 13:36 tty29
crw-------   1 root  root      4,   3 Jul 12 13:38 tty3
crw--w----   1 root  tty       4,  30 Jul 12 13:36 tty30
crw--w----   1 root  tty       4,  31 Jul 12 13:36 tty31
crw--w----   1 root  tty       4,  32 Jul 12 13:36 tty32
crw--w----   1 root  tty       4,  33 Jul 12 13:36 tty33
crw--w----   1 root  tty       4,  34 Jul 12 13:36 tty34
crw--w----   1 root  tty       4,  35 Jul 12 13:36 tty35
crw--w----   1 root  tty       4,  36 Jul 12 13:36 tty36
crw--w----   1 root  tty       4,  37 Jul 12 13:36 tty37
crw--w----   1 root  tty       4,  38 Jul 12 13:36 tty38
crw--w----   1 root  tty       4,  39 Jul 12 13:36 tty39
crw-------   1 root  root      4,   4 Jul 12 13:38 tty4
crw--w----   1 root  tty       4,  40 Jul 12 13:36 tty40
crw--w----   1 root  tty       4,  41 Jul 12 13:36 tty41
crw--w----   1 root  tty       4,  42 Jul 12 13:36 tty42
crw--w----   1 root  tty       4,  43 Jul 12 13:36 tty43
crw--w----   1 root  tty       4,  44 Jul 12 13:36 tty44
crw--w----   1 root  tty       4,  45 Jul 12 13:36 tty45
crw--w----   1 root  tty       4,  46 Jul 12 13:36 tty46
crw--w----   1 root  tty       4,  47 Jul 12 13:36 tty47
crw--w----   1 root  tty       4,  48 Jul 12 13:36 tty48
crw--w----   1 root  tty       4,  49 Jul 12 13:36 tty49
crw-------   1 root  root      4,   5 Jul 12 13:38 tty5
crw--w----   1 root  tty       4,  50 Jul 12 13:36 tty50
crw--w----   1 root  tty       4,  51 Jul 12 13:36 tty51
crw--w----   1 root  tty       4,  52 Jul 12 13:36 tty52
crw--w----   1 root  tty       4,  53 Jul 12 13:36 tty53
crw--w----   1 root  tty       4,  54 Jul 12 13:36 tty54
crw--w----   1 root  tty       4,  55 Jul 12 13:36 tty55
crw--w----   1 root  tty       4,  56 Jul 12 13:36 tty56
crw--w----   1 root  tty       4,  57 Jul 12 13:36 tty57
crw--w----   1 root  tty       4,  58 Jul 12 13:36 tty58
crw--w----   1 root  tty       4,  59 Jul 12 13:36 tty59
crw-------   1 root  root      4,   6 Jul 12 13:38 tty6
crw--w----   1 root  tty       4,  60 Jul 12 13:36 tty60
crw--w----   1 root  tty       4,  61 Jul 12 13:36 tty61
crw--w----   1 root  tty       4,  62 Jul 12 13:36 tty62
crw--w----   1 root  tty       4,  63 Jul 12 13:36 tty63
crw--w----   1 root  tty       4,   7 Jul 12 13:36 tty7
crw--w----   1 root  tty       4,   8 Jul 12 13:36 tty8
crw--w----   1 root  tty       4,   9 Jul 12 13:36 tty9
crw-rw----   1 root  dialout   4,  64 Jul 12 13:36 ttyS0
crw-rw----   1 root  dialout   4,  65 Jul 12 13:36 ttyS1
crw-rw----   1 root  dialout   4,  66 Jul 12 13:36 ttyS2
crw-rw----   1 root  dialout   4,  67 Jul 12 13:36 ttyS3
crw-------   1 root  root     10, 223 Jul 12 13:36 uinput
crw-rw-rw-   1 root  root      1,   9 Jul 12 13:36 urandom
crw-------   1 root  root    252,   0 Jul 12 13:36 usbmon0
crw-------   1 root  root    252,   1 Jul 12 13:36 usbmon1
crw-------   1 root  root    252,   2 Jul 12 13:36 usbmon2
crw-------   1 root  root    252,   3 Jul 12 13:36 usbmon3
crw-------   1 root  root    252,   4 Jul 12 13:36 usbmon4
crw-rw----   1 root  tty       7,   0 Jul 12 13:36 vcs
crw-rw----   1 root  tty       7,   1 Jul 12 13:36 vcs1
crw-rw----   1 root  tty       7,   2 Jul 12 13:38 vcs2
crw-rw----   1 root  tty       7,   3 Jul 12 13:38 vcs3
crw-rw----   1 root  tty       7,   4 Jul 12 13:38 vcs4
crw-rw----   1 root  tty       7,   5 Jul 12 13:38 vcs5
crw-rw----   1 root  tty       7,   6 Jul 12 13:38 vcs6
crw-rw----   1 root  tty       7,   7 Jul 12 13:39 vcs7
crw-rw----   1 root  tty       7, 128 Jul 12 13:36 vcsa
crw-rw----   1 root  tty       7, 129 Jul 12 13:36 vcsa1
crw-rw----   1 root  tty       7, 130 Jul 12 13:38 vcsa2
crw-rw----   1 root  tty       7, 131 Jul 12 13:38 vcsa3
crw-rw----   1 root  tty       7, 132 Jul 12 13:38 vcsa4
crw-rw----   1 root  tty       7, 133 Jul 12 13:38 vcsa5
crw-rw----   1 root  tty       7, 134 Jul 12 13:38 vcsa6
crw-rw----   1 root  tty       7, 135 Jul 12 13:39 vcsa7
crw-------   1 root  root     10,  63 Jul 12 13:36 vga_arbiter
drwxr-xr-x   2 root  root          80 Jul 12 13:36 vg_F15
crw-------   1 root  root     10, 130 Jul 12 13:36 watchdog
crw-rw-rw-   1 root  root      1,   5 Jul 12 13:36 zero
Comment 1 Xtian Simon 2011-07-12 19:03:33 EDT
Additional info: 
4G USB/Thumbdrive automounts, OK.
Comment 2 Karel Zak 2011-07-13 04:59:38 EDT
Please, I'd like to see:

  blkid -p -o udev /dev/dvd

(or replace "/dev/dvd" with device where is the filesystem). See also "lsblk --fs" output.
Comment 3 Xtian Simon 2011-07-13 09:22:08 EDT
1.) # blkid -p -o udev /dev/dvd 
/* also tried /dev/cdrom, /dev/sr0 */
> Returns = Nothing?

2.) # lsblk --fs 
> Returns=
NAME                                                     FSTYPE   LABEL MOUNTPOINT
sda                                                                     
├─sda1                                                   vfat           
├─sda2                                                   ext4           /boot
└─sda3                                                   crypto_L       
  └─luks-2145471a-de7e-4ed4-b771-a565213de6bf (dm-0)     LVM2_mem       
    ├─vg_F15-vg_root (dm-1)                              crypto_L       
    │ └─luks-6caf0b39-564c-4088-a585-ec808472caa8 (dm-3) ext4           /
    └─vg_F15-vg_swap (dm-2)                              crypto_L       
sr0
Comment 4 Xtian Simon 2011-07-16 18:16:48 EDT
Update:
As I stated, non-hfs disks will automount. However, when using X windows I am constantly made aware of mount errors.

* Failed to execute default File Manager. Failed to execute child process "file manager" (No such file or directory).

* Unable to mount [disk]. DBus error org.gtk. Private.RemoteVolumeMonitor.Failed An operation is already pending.

I'm guessing this is because I have opted to install both GDE and KDE XWindows. What I was lead to believe, based on the information I read, was these are independent sets of preferences--that I could test both at the same time, using different startx commands or .xinitrc files to chose which to use at a given time.

I've not tested the KDE environment yet, however, I've discovered in the GDE the introduction of multiple applications which do the same things. So I have two terminal apps, three text editors (Kate, Kwrite, leafpad), etc. 

Of course none of these issues should cause the command line mount problems I am experiencing.
Comment 5 Xtian Simon 2011-07-24 13:28:07 EDT
UPDATE= 
Still broken after re-installation of the system. Currently system installed as minimal Fedora 15 Xfce with WM (Openbox, & Xfce). 

Here is the new setup:
# lsblk --fs 
>Returns
NAME                                      FSTYPE     LABEL MOUNTPOINT
sda                                                                   
├─sda1                                    vfat             
├─sda2                                    ext4             /boot
└─sda3                                    crypto_LUK       
  └─luks-BLABLA (dm-0) LVM2_membe       
    ├─cryptVG-root (dm-1)                 ext4             /
    ├─cryptVG-swap (dm-2)                 swap             [SWAP]
    └─cryptVG-data (dm-3)                 ext4             /home
sr0         

And the disk still mounts on MacOSX 10.4.
Comment 6 Mephisto 2011-08-01 07:50:05 EDT
This is not specific to optical disks, but also happens with other hfsplus filesystems, like my iPod. It worked fine in F14 and under F15 I get the following:

[71589.792690] sd 9:0:0:0: [sdi] Attached SCSI removable disk
[71590.496050] sd 9:0:0:0: [sdi] Bad block number requested
[71590.496066] hfs: unable to find HFS+ superblock
[71590.639044] sd 9:0:0:0: [sdi] Bad block number requested
[71590.639059] hfs: unable to find HFS+ superblock

I found this thread on Arch forums, saying it's a problem with the hfsplus module in the 2.6.38 kernel.
https://bbs.archlinux.org/viewtopic.php?pid=925581
At the moment I'm using 2.6.38.8-35.fc15.i686.PAE, which I'm pretty sure is the latest at the moment I'm typing this.

The proper way to solve this is to fix the kernel module.
Although I can live without syncing my iPod for a little while, I would really like to see this fixed soon... Surely a lot of people with iPods and F15 systems would be running into issues? Unless they're all using an inferior MS filesystem on it ofcourse...
Comment 7 Mephisto 2011-08-01 07:53:13 EDT
Oh yeah, and can someone set the Component to the kernel instead of util-linux, as this is not a util-linux issue?
Comment 8 Josh Boyer 2011-08-02 08:03:26 EDT
kernel-2.6.40-4.fc15 has been pushed to updates.  Could you test that kernel and let us know if the problem still exists?  If so, there is one additional change that might need to be brought back.
Comment 9 Mephisto 2011-08-02 10:09:58 EDT
Nope, sorry, still the same error:

[mephisto@chii ~]$ uname -a
Linux chii 2.6.40-4.fc15.i686.PAE #1 SMP Fri Jul 29 18:47:58 UTC 2011 i686 i686 i386 GNU/Linux
[mephisto@chii ~]$ dmesg |tail -n 5
[   95.098940] sd 9:0:0:0: [sdi] Attached SCSI removable disk
[   95.440234] sd 9:0:0:0: [sdi] Bad block number requested
[   95.440246] hfs: unable to find HFS+ superblock
[   95.492236] sd 9:0:0:0: [sdi] Bad block number requested
[   95.492252] hfs: unable to find HFS+ superblock
Comment 10 Josh Boyer 2011-08-02 13:43:00 EDT
OK, I grabbed one more patch from what will be the 3.1 kernel.  Could you test this build when it completes?

http://koji.fedoraproject.org/koji/taskinfo?taskID=3247290
Comment 11 Mephisto 2011-08-02 19:01:17 EDT
This kernel seems to fix the issue. I can access the file system after it has been automounted and I've just finished syncing my ipod with hfs+ filesystem with rhythmbox with no problems at all.
Comment 12 Josh Boyer 2011-08-02 19:13:41 EDT
Excellent, thank you for testing!
Comment 13 Xtian Simon 2011-08-03 14:52:23 EDT
Command line mount works, woot! 
I can mount the DVD manually and copy a file. 

Dolphin and Thunar File Managers are not automounting the DVD.
I installed:

    kernel-2.6.40-5.fc15.i686.rpm 
    kernel-headers-2.6.40-5.fc15.i686.rpm 

Settings I've checked:
Xfce > Applications Menu > Preferences > Removable Drives & Media 
- Mount ... when hot plugged 
- Mount ... when inserted 
- Browse ... when  inserted

Xfce > Applications Menu > Preferences > File Manager 
+ [Advanced]
|- Enable volume management (?)
Comment 14 Mephisto 2011-08-03 20:21:09 EDT
If you can mount the DVD from commandline, but it does not get automounted, you're running into 2 separate bugs, and you should probably open a new ticket for the Dolphin bug, to prevent confusing developers ;) If commandline mounting works, the "unable to find superblock" kernel issue is gone.
Comment 15 Xtian Simon 2011-08-04 20:21:03 EDT
For continuing problems with HFS+ DVD disks, I've added a new bug report as per Mephesto's suggestion.

Bug 728398 - Dolphin, Thunar, (and Nautilus) File Managers do not automount HFS+ DVDs in F15
[url=https://bugzilla.redhat.com/show_bug.cgi?id=728398]
Comment 16 Xtian Simon 2011-08-08 10:56:17 EDT
The problem for DVDs still exists. I was testing all of these troubles with my latest DVD backup. While restoring my system, I required an older DVD backup. The newer backup (Dsik 1) was made using OS X's Disk Utility or was a Burn Folder. The older backup (Disk 2) was likely made with a third party burn app (Dragon Burn).

I don't know what to provide to assist with this troubleshooting. Below I've included the commands I used to mount and umount the disks (duh) and OS X diskutil's output. 

--
Here is the screen output with commands and errors=
> INSERTED DISK 2...
# mount -t hfsplus /dev/dvd /media 
mount: block device /dev/sr0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sr0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
> EJECTED THE DISK AND INSERTED DISK 1...
# mount -t hfsplus /dev/dvd /media
mount: block device /dev/sr0 is write-protected, mounting read-only
mount: /dev/sr0 already mounted or /media busy
mount: according to mtab, tmpfs is already mounted on /media
# ls /media
> LIST SHOWS NOTHING, SO I THREW IN A FEW UMOUNTS...
# umount /media
umount: /media: device is busy.
        (In some cases useful info about processes that use
         the device is found by lsof(8) or fuser(1))
# umount -f /media
umount2: Device or resource busy
umount: /media: device is busy.
        (In some cases useful info about processes that use
         the device is found by lsof(8) or fuser(1))
umount2: Device or resource busy
# mount -t hfsplus /dev/dvd /media
mount: block device /dev/sr0 is write-protected, mounting read-only
# ls /media
Desktop DB  Desktop DF  etc  root  www  Xtian
> DISK 1 STILL MOUNTS...

--
Here is OS X's diskutil command report on the two disks=
DISK 1 (mounts ok)
   Device Node:        /dev/disk2s2
   Device Identifier:  disk2s2
   Mount Point:        /Volumes/F11-Backup
   Volume Name:        F11-Backup

   File System:        HFS+
   Owners:             Disabled
   Partition Type:     Apple_HFS
   Bootable:           Is bootable
   Media Type:         Generic
   Protocol:           ATAPI
   SMART Status:       Not Supported
   UUID:               0B8A7FC9-64EA-3866-A429-241191447E3C

   Total Size:         4.4 GB
   Free Space:         1.5 GB

   Read Only:          Yes
   Ejectable:          Yes

   Drive Type:         CD-ROM, CD-R, CD-RW, DVD-ROM, DVD-R, DVD-RW, DVD-RAM, DVD+R, DVD+RW
   Media Type:         DVD-R
   Erasable:           No

--
DISK 2 (fails to mount) 
   Device Node:        /dev/disk2s2
   Device Identifier:  disk2s2
   Mount Point:        /Volumes/Backup OSX+F11
   Volume Name:        Backup OSX+F11

   File System:        HFS+
   Owners:             Disabled
   Partition Type:     Apple_HFS
   Bootable:           Is bootable
   Media Type:         Generic
   Protocol:           ATAPI
   SMART Status:       Not Supported
   UUID:               00000000-0000-0000-0000-000000000000

   Total Size:         3.4 GB
   Free Space:         0.0 B

   Read Only:          Yes
   Ejectable:          Yes

   Drive Type:         CD-ROM, CD-R, CD-RW, DVD-ROM, DVD-R, DVD-RW, DVD-RAM, DVD+R, DVD+RW
   Media Type:         DVD-R
   Erasable:           No
Comment 17 Mephisto 2011-08-08 11:52:00 EDT
Well, this could either mean that 1) the patch was incomplete and doesn't work for every HFS+ volume, or 2) there is actually something wrong with your 2nd disk. Keep in mind that writeable optical disks aren't the most reliable backup media ever (scratches, disk-rot, etc).
Does the dvd mount properly in other systems, like OS X, other linux versions or (ugh) windoze?

I dunno much about OS X's diskutil, but this looks curious to me:

disk 1:
Total Size:         4.4 GB
Free Space:         1.5 GB

disk 2:
Total Size:         3.4 GB
Free Space:         0.0 B

To my knowledge, there are no dvd disks with 3.4GB capacity... unless it's a difference between finalized and unfinalized disks, or something similar, although if that's the case, it's displayed a bit weird and inconsistent...
Comment 18 Fedora Update System 2011-08-08 20:04:51 EDT
kernel-3.0.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.0.1-3.fc16
Comment 19 Fedora Update System 2011-08-08 22:53:22 EDT
Package kernel-3.0.1-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.0.1-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-3.0.1-3.fc16
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2011-08-16 08:47:26 EDT
kernel-2.6.40.3-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
Comment 21 Fedora Update System 2011-08-17 22:30:18 EDT
kernel-2.6.40.3-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2011-08-22 10:50:15 EDT
kernel-3.0.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Xtian Simon 2011-08-31 15:50:05 EDT
Regarding bug 720771 and current kernel 2.6.40.3-0.fc15.i686. The problem outlined in both comment #16:
   https://bugzilla.redhat.com/show_bug.cgi?id=720771#c16

...of this original bug report and in the kernel update kernel-2.6.40.3-0.fc15:
   https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15

...remain a problem. 

I'm sure the contributors to the Fedora project will agree in the case of archiving media we should all wish to have access our archives well into the future. (^_^)

I tested additional media I know I used on my previous F11 system (which never had one problem). I had a CDROM which does auto-mount in Xfce, yet the following repeatable errors were generated,
   # mount -t hfsplus /dev/cdrom /media/cdrom  /* where cdrom is a dir I created */
   [709...] hfs: invalid btree flag
   [709...] hfs: failed to load extents file 
   #startx
This resulted in a flury of errors and a frozen screen.
Attempting to restart with CTRL+ALT+DELETE I managed to get a few extra errors before I needed to unplug,
   [824...] umount 2687 /proc/fs/nfsd: device is busy
   [824...] umount (In some cases...)
   [824...] umount /var/lib/nfs/rpc_pipefs: device is busy
   [824...] umount (In some cases
   [824...] umount the device is found by lsof(8) or fuser(1)
   [824...] umount the device is found by lsof(8) or fuser(1)

Note You need to log in before you can comment on or make changes to this bug.