Bug 720822 - Huawei E220 3g Modem times out and does not connect
Huawei E220 3g Modem times out and does not connect
Status: CLOSED DUPLICATE of bug 717727
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-12 17:58 EDT by Louis van Dyk
Modified: 2012-04-25 05:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-31 06:45:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Louis van Dyk 2011-07-12 17:58:24 EDT
Description of problem: When I plug in my Huawei modem (E220) it is detected by Fedora.  NetworkManager notes that a modem has been connected and runs the wizard allowing me to choose my ISP. I click on the created name, and it proceeds to try to connect.  The taskbar icon changes to three dots.  However, in the message log it shows that it times out.  See the logs at the end of this report.


Version-Release number of selected component (if applicable):
I first tried on: ModemManager-0.4.997-1.fc15.x86_64
And also on: ModemManager-0.4.998-1.git20110706.fc15.x86_64
I am using: NetworkManager-0.8.9997-4.git20110620.fc15.x86_64


How reproducible:
Every time.

Steps to Reproduce:
1. Plug the USB Modem into the notebook.
2. Click on NetworkManager icon on the system tray. Click Mobile Broadband to ON.
3. Click on MTN Default - the defined config for my ISP.
4. The device begins to authenticate.
5. THe process times out.
  
Actual results:
As above.

Expected results:
The connection should authenticate and get an IP address and allow me to connect to the Internet.

Additional info:
I am logging this ticket on the SAME notebook, on the SAME Fedora 15 host, using a VirtualBox instance with an XP guest.

lsusb shows:
Bus 005 Device 004: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E230/E270 HSDPA/HSUPA Modem

When I plug the modem in:
Jul 12 23:50:17 lvd-pc kernel: [73691.733089] usb 5-1: new full speed USB device using uhci_hcd and address 9
Jul 12 23:50:17 lvd-pc kernel: [73691.880106] usb 5-1: New USB device found, idVendor=12d1, idProduct=1003
Jul 12 23:50:17 lvd-pc kernel: [73691.880116] usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jul 12 23:50:17 lvd-pc kernel: [73691.880124] usb 5-1: Product: HUAWEI Mobile
Jul 12 23:50:17 lvd-pc kernel: [73691.880130] usb 5-1: Manufacturer: HUAWEI Technologies
Jul 12 23:50:17 lvd-pc kernel: [73691.885175] scsi33 : usb-storage 5-1:1.0
Jul 12 23:50:17 lvd-pc mtp-probe: checking bus 5, device 9: "/sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1"
Jul 12 23:50:17 lvd-pc kernel: [73691.954134] usb 5-1: USB disconnect, address 9
Jul 12 23:50:17 lvd-pc mtp-probe: bus: 5, device: 9 was not an MTP device
Jul 12 23:50:17 lvd-pc kernel: [73692.660082] usb 5-1: new full speed USB device using uhci_hcd and address 10
Jul 12 23:50:18 lvd-pc kernel: [73692.807098] usb 5-1: New USB device found, idVendor=12d1, idProduct=1003
Jul 12 23:50:18 lvd-pc kernel: [73692.807102] usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jul 12 23:50:18 lvd-pc kernel: [73692.807105] usb 5-1: Product: HUAWEI Mobile
Jul 12 23:50:18 lvd-pc kernel: [73692.807108] usb 5-1: Manufacturer: HUAWEI Technologies
Jul 12 23:50:18 lvd-pc kernel: [73692.815577] option 5-1:1.0: GSM modem (1-port) converter detected
Jul 12 23:50:18 lvd-pc kernel: [73692.815752] usb 5-1: GSM modem (1-port) converter now attached to ttyUSB0
Jul 12 23:50:18 lvd-pc kernel: [73692.819401] option 5-1:1.1: GSM modem (1-port) converter detected
Jul 12 23:50:18 lvd-pc kernel: [73692.819559] usb 5-1: GSM modem (1-port) converter now attached to ttyUSB1
Jul 12 23:50:18 lvd-pc kernel: [73692.821460] scsi36 : usb-storage 5-1:1.2
Jul 12 23:50:18 lvd-pc mtp-probe: checking bus 5, device 10: "/sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1"
Jul 12 23:50:18 lvd-pc mtp-probe: bus: 5, device: 10 was not an MTP device
Jul 12 23:50:18 lvd-pc modem-manager[1083]: <info>  (ttyUSB0) opening serial port...
Jul 12 23:50:19 lvd-pc kernel: [73693.826130] scsi 36:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
Jul 12 23:50:19 lvd-pc kernel: [73693.845977] sr1: scsi-1 drive
Jul 12 23:50:19 lvd-pc kernel: [73693.846805] sr 36:0:0:0: Attached scsi generic sg3 type 5
Jul 12 23:50:21 lvd-pc modem-manager[1083]: <info>  (ttyUSB0) closing serial port...
Jul 12 23:50:21 lvd-pc modem-manager[1083]: <info>  (ttyUSB0) serial port closed
Jul 12 23:50:21 lvd-pc modem-manager[1083]: <info>  (ttyUSB0) opening serial port...
Jul 12 23:50:21 lvd-pc modem-manager[1083]: <info>  (Huawei): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1 claimed port ttyUSB0
Jul 12 23:50:21 lvd-pc modem-manager[1083]: <info>  (ttyUSB0) closing serial port...
Jul 12 23:50:21 lvd-pc modem-manager[1083]: <info>  (ttyUSB0) serial port closed
Jul 12 23:50:24 lvd-pc modem-manager[1083]: <info>  (ttyUSB1) opening serial port...
Jul 12 23:50:25 lvd-pc modem-manager[1083]: <info>  (ttyUSB1) closing serial port...
Jul 12 23:50:25 lvd-pc modem-manager[1083]: <info>  (ttyUSB1) serial port closed
Jul 12 23:50:25 lvd-pc modem-manager[1083]: <info>  (Huawei): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1 claimed port ttyUSB1
Jul 12 23:50:25 lvd-pc NetworkManager[1009]: <warn> (ttyUSB0): failed to look up interface index
Jul 12 23:50:25 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): new GSM/UMTS device (driver: 'option1' ifindex: -1)
Jul 12 23:50:25 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): exported as /org/freedesktop/NetworkManager/Devices/5
Jul 12 23:50:25 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): now managed
Jul 12 23:50:25 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Jul 12 23:50:25 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): deactivating device (reason: 2).
Jul 12 23:50:25 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): device state change: unavailable -> disconnected (reason 'none') [20 30 0]

When I click Mobile Broadband ON:
Jul 12 23:51:54 lvd-pc modem-manager[1083]: <info>  (ttyUSB0) opening serial port...
Jul 12 23:51:54 lvd-pc modem-manager[1083]: <info>  Modem /org/freedesktop/ModemManager/Modems/3: state changed (disabled -> enabling)
Jul 12 23:51:54 lvd-pc modem-manager[1083]: <info>  (ttyUSB1) opening serial port...
Jul 12 23:51:54 lvd-pc modem-manager[1083]: Invalid error code: 303
Jul 12 23:51:54 lvd-pc modem-manager[1083]: <info>  Modem /org/freedesktop/ModemManager/Modems/3: state changed (enabling -> enabled)
Jul 12 23:51:54 lvd-pc NetworkManager[1009]: <info> WWAN now enabled by management service
Jul 12 23:51:54 lvd-pc modem-manager[1083]: <info>  Modem /org/freedesktop/ModemManager/Modems/3: state changed (enabled -> registered)

When I click MTN Default (the ISP Profile created):
Jul 12 23:53:13 lvd-pc NetworkManager[1009]: <info> Activation (ttyUSB0) starting connection 'MTN Default'
Jul 12 23:53:13 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Jul 12 23:53:13 lvd-pc NetworkManager[1009]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Jul 12 23:53:13 lvd-pc NetworkManager[1009]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Jul 12 23:53:13 lvd-pc NetworkManager[1009]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.

After a period of about 15 seconds:
Jul 12 23:53:40 lvd-pc NetworkManager[1009]: <warn> GSM connection failed: (32) Serial command timed out
Jul 12 23:53:40 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): device state change: prepare -> failed (reason 'unknown') [40 120 1]
Jul 12 23:53:40 lvd-pc NetworkManager[1009]: <warn> Activation (ttyUSB0) failed.
Jul 12 23:53:40 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Jul 12 23:53:40 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): deactivating device (reason: 0).

When I unplug the Huawei modem:
Jul 12 23:54:11 lvd-pc kernel: [73926.454126] usb 5-1: USB disconnect, address 10
Jul 12 23:54:11 lvd-pc modem-manager[1083]: <info>  (ttyUSB0) closing serial port...
Jul 12 23:54:11 lvd-pc modem-manager[1083]: <info>  (ttyUSB0) serial port closed
Jul 12 23:54:11 lvd-pc modem-manager[1083]: <info>  (ttyUSB1) closing serial port...
Jul 12 23:54:11 lvd-pc modem-manager[1083]: <info>  (ttyUSB1) serial port closed
Jul 12 23:54:11 lvd-pc kernel: [73926.455891] option: option_instat_callback: error -108
Jul 12 23:54:11 lvd-pc kernel: [73926.456240] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
Jul 12 23:54:11 lvd-pc kernel: [73926.456273] option 5-1:1.0: device disconnected
Jul 12 23:54:11 lvd-pc kernel: [73926.456604] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
Jul 12 23:54:11 lvd-pc kernel: [73926.456633] option 5-1:1.1: device disconnected
Jul 12 23:54:11 lvd-pc modem-manager[1083]: <info>  (tty/ttyUSB1): released by modem /sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1
Jul 12 23:54:11 lvd-pc modem-manager[1083]: <info>  (tty/ttyUSB0): released by modem /sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1
Jul 12 23:54:11 lvd-pc modem-manager[1083]: <info>  Modem /org/freedesktop/ModemManager/Modems/3: state changed (registered -> disabled)
Jul 12 23:54:11 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): now unmanaged
Jul 12 23:54:11 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): device state change: disconnected -> unmanaged (reason 'removed') [30 10 36]
Jul 12 23:54:11 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): cleaning up...
Jul 12 23:54:11 lvd-pc NetworkManager[1009]: <info> (ttyUSB0): taking down device.
Comment 1 Louis van Dyk 2011-07-18 12:24:09 EDT
Network Manager package was updated today to:
NetworkManager-glib.x86_64 1:0.8.9997-5.git20110702.fc15

This has made no difference to the problem.
Comment 2 Louis van Dyk 2011-08-31 06:44:16 EDT
Bug 717727 seems to report a similar case as this.

However, although I downgraded to ModemManager-0.4-7.git20110201.fc15.x86_64, this also does NOT work.
Comment 3 Louis van Dyk 2011-08-31 06:45:36 EDT

*** This bug has been marked as a duplicate of bug 717727 ***
Comment 4 idaho 2011-10-16 04:08:15 EDT
I think this bug is NOT a duplicate of bug 717727.
The symptoms are different (as you can see in debug logs).
I mean this line:
Jul 12 23:50:21 lvd-pc modem-manager[1083]: <info>  (ttyUSB0) opening serial
port...
Jul 12 23:50:21 lvd-pc modem-manager[1083]: <info>  (Huawei): GSM modem
/sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1 claimed port ttyUSB0

In this bug report, modem is detected after sending AT^CURC=0 and AT^GETPORTMODE commands (second line here), while in bug 717727 this doesn't happen and ttyUSB0 gets closed without getting thus far.

Please reference my comment here for more details: https://bugzilla.redhat.com/show_bug.cgi?id=717727#c10
Comment 5 Nuno Anjos 2012-04-25 05:53:36 EDT
I have a HUAWEI E220, and for it to work, i have to:
- insert de modem
- wait for NetworkManager detects
(i have also instaled vodafone-mobile-connect-card-driver-for-linux) that
works, but i prefer to have NetworkManager only)
- i start vodafone-mobile-connect-card-driver-for-linux and then click on the
link in Networkmanager.

same how the startup functions in
vodafone-mobile-connect-card-driver-for-linux, makes NetworkManager start
getting green and i stop vodafone-mobile-connect-card-driver-for-linux, and
NetworkManager captures the modem connection.

This is the only way i get it to work.

Now i have another probleam, each time i connect my samsung ace (android) to
charge. NetworkManager loses de HUAWEI connection a makes a connection via the
phone. 
i can't have the 2 modem's connected at the same time. It seems that
NetworkManager can't distinguish between the modem's.

Note You need to log in before you can comment on or make changes to this bug.