This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 720836 - [epiphany] fails to execute Java applets
[epiphany] fails to execute Java applets
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: icedtea-web (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: jiri vanek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-12 18:51 EDT by Joachim Frieben
Modified: 2014-06-16 09:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 03:42:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2011-07-12 18:51:27 EDT
Description of problem:
When running the Java version check at http://www.javatester.org/version.html then the applet frame shows the icon for a missing plugin. In the same time, epiphany returns an error message to the console from which it had been launched:

** (epiphany:2214): DEBUG: NP_Initialize
** (epiphany:2214): DEBUG: NP_Initialize succeeded
** (epiphany:2214): DEBUG: NP_Initialize
** (epiphany:2214): DEBUG: NP_Initialize succeeded
*** NSPlugin Wrapper *** ERROR: NP_Initialize() wait for reply: Connection closed
** (epiphany:2214): DEBUG: NP_Initialize
** (epiphany:2214): DEBUG: NP_Initialize succeeded
** (epiphany:2214): DEBUG: NP_Initialize
** (epiphany:2214): DEBUG: NP_Initialize succeeded
ERROR: Invalid browser function table. Some functionality may be restricted.
** (epiphany:2214): DEBUG: NP_Initialize
** (epiphany:2214): DEBUG: NP_Initialize succeeded
** (epiphany:2214): DEBUG: NP_Initialize
** (epiphany:2214): DEBUG: NP_Initialize succeeded
** (epiphany:2214): DEBUG: NP_Initialize
** (epiphany:2214): DEBUG: NP_Initialize succeeded
** (epiphany:2214): DEBUG: NP_Initialize
** (epiphany:2214): DEBUG: NP_Initialize succeeded
java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.2) (fedora-58.1.10.2.fc16-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)
*** NSPlugin Wrapper *** WARNING:(../src/npw-wrapper.c:3558):invoke_NP_Initialize: assertion failed: (rpc_method_invoke_possible(g_rpc_connection))
ERROR: Invalid browser function table. Some functionality may be restricted.

Version-Release number of selected component (if applicable):
epiphany-3.1.3-1.fc16

How reproducible:
Always.

Steps to Reproduce:
1. Open http://www.javatester.org/version.html
  
Actual results:
Browser shows no action, only the missing plugin icon is displayed.

Expected results:
Applet gets executed, and the current Java version is reported.

Additional info:
Webkit based browser midori behaves correctly in this test case.
Comment 1 Joachim Frieben 2011-11-06 02:17:33 EST
No improvement whatsoever for current F16 including packages epiphany-3.2.1-2.fc16 and java-1.6.0-openjdk-1.6.0.0-60.1.10.4.fc16:

Gtk-Message: Failed to load module "pk-gtk-module"
** (epiphany:9562): DEBUG: NP_Initialize
** (epiphany:9562): DEBUG: NP_Initialize succeeded
** (epiphany:9562): DEBUG: NP_Initialize
** (epiphany:9562): DEBUG: NP_Initialize succeeded
** (epiphany:9562): DEBUG: NP_Initialize
** (epiphany:9562): DEBUG: NP_Initialize succeeded
** (epiphany:9562): DEBUG: NP_Initialize
** (epiphany:9562): DEBUG: NP_Initialize succeeded
ERROR: Invalid browser function table. Some functionality may be restricted.
(epiphany:9562): GnomeShellBrowserPlugin-DEBUG: plugin loaded
java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.4) (fedora-60.1.10.4.fc16-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)

(epiphany:9562): libsoup-CRITICAL **: soup_message_io_pause: assertion `io != NULL' failed

(epiphany:9562): libsoup-CRITICAL **: soup_message_io_unpause: assertion `io != NULL' failed
Comment 2 Martin Stransky 2012-02-15 04:57:21 EST
Peter works on epiphany now.
Comment 3 Peter Hatina 2012-05-28 09:55:28 EDT
The problem resides in the IcedTeaPlugin. This plugin is compiled against GTK+ 2.x libraries and thus it makes troubles to epiphany to use this plugin. I have already sent a patch to IcedTea project to add options to compile the project with either GTK+ 2.x or 3.x. When compiled with GTK+ 3.x, java applets work flawlessly. Maybe, we will need to have both builds (rpms) of the IcedTeaPlugin installed to make webkitgtk and webkitgtk3 browsers work well.
Comment 4 Fedora Update System 2012-09-18 11:39:08 EDT
icedtea-web-1.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/icedtea-web-1.3-1.fc17
Comment 5 Fedora Update System 2012-09-18 11:39:33 EDT
icedtea-web-1.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/icedtea-web-1.3-1.fc16
Comment 6 Fedora Update System 2012-09-18 11:39:51 EDT
icedtea-web-1.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/icedtea-web-1.3-1.fc18
Comment 7 Fedora Update System 2012-09-18 22:58:51 EDT
Package icedtea-web-1.3-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing icedtea-web-1.3-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14316/icedtea-web-1.3-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-09-21 19:52:47 EDT
icedtea-web-1.3-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-09-21 19:56:19 EDT
icedtea-web-1.3-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-09-25 02:18:45 EDT
icedtea-web-1.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Joachim Frieben 2012-09-25 04:49:52 EDT
No improvement for epiphany-3.2.2-4.fc16 with icedtea-web-1.3-2.fc16 and http://www.javatester.org/version.html

$ epiphany 
** (epiphany:2111): DEBUG: NP_Initialize
** (epiphany:2111): DEBUG: NP_Initialize succeeded
** (epiphany:2111): DEBUG: NP_Initialize
** (epiphany:2111): DEBUG: NP_Initialize succeeded
** (epiphany:2111): DEBUG: NP_Initialize
** (epiphany:2111): DEBUG: NP_Initialize succeeded
** (epiphany:2111): DEBUG: NP_Initialize
** (epiphany:2111): DEBUG: NP_Initialize succeeded
(epiphany:2111): GnomeShellBrowserPlugin-DEBUG: plugin loaded
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4) (fedora-68.1.11.4.fc16-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
Comment 12 Deepak Bhole 2012-09-25 10:18:23 EDT
(In reply to comment #11)
> No improvement for epiphany-3.2.2-4.fc16 with icedtea-web-1.3-2.fc16 and
> http://www.javatester.org/version.html
> 
> $ epiphany 
> ** (epiphany:2111): DEBUG: NP_Initialize
> ** (epiphany:2111): DEBUG: NP_Initialize succeeded
> ** (epiphany:2111): DEBUG: NP_Initialize
> ** (epiphany:2111): DEBUG: NP_Initialize succeeded
> ** (epiphany:2111): DEBUG: NP_Initialize
> ** (epiphany:2111): DEBUG: NP_Initialize succeeded
> ** (epiphany:2111): DEBUG: NP_Initialize
> ** (epiphany:2111): DEBUG: NP_Initialize succeeded
> (epiphany:2111): GnomeShellBrowserPlugin-DEBUG: plugin loaded
> java version "1.6.0_24"
> OpenJDK Runtime Environment (IcedTea6 1.11.4) (fedora-68.1.11.4.fc16-x86_64)
> OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

Not sure I understand. I don't see any errors above unlike in the original report. Is the applet not loading for you?
Comment 13 Joachim Frieben 2012-10-07 06:41:59 EDT
For icedtea-web-1.3-1.fc17 the situation is the following:

- firefox-15.0.1-1.fc17:
* http://www.javatester.org/version.html works but the page needs to be reloaded in order to actually obtain the version message in the present pink rectangle
* http://www.java.com/en/download/installed.jsp?detect=jre executes but the spinner keeps on turning indefinitely

- epiphany-3.4.3-1.fc17:
* http://www.javatester.org/version.html does not work at all. There is no activity which shows that the applet is being executed nor an error message in the shell when epiphany is launched from there.
* http://www.java.com/en/download/installed.jsp?detect=jre returns:
"Verify Java Version
No working Java was detected on your system. Install Java by clicking the button below."
Comment 14 Deepak Bhole 2012-12-12 14:57:02 EST
Jiri, can you please take a look when you get a chance? Thanks!
Comment 15 jiri vanek 2012-12-13 03:42:58 EST
Yes. Icedtea-web is compiled against gtk2 => working in midory, not in epiphany. Sorry.

However I'm running custom builds on gtk3 and everything is working fine. 
So you can make custom build (the plain rebuild of rpm with changed gtk in spec or sources+make will do) and  everything will work.

But thank you for reminder, because for f18 we MUST switch icedtea-web to gtk3. I will rise flag for Deepak as maintainer.
Comment 16 Deepak Bhole 2014-06-16 09:52:43 EDT
Clearing NEEDINFO on closed bug.

Note You need to log in before you can comment on or make changes to this bug.