This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 720884 - gnome-shell freeze while terminating ibus
gnome-shell freeze while terminating ibus
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-13 01:43 EDT by Akira TAGOH
Modified: 2011-07-18 18:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-1.3.99.20110419-11.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-18 18:46:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2011-07-13 01:43:02 EDT
Description of problem:
summary says it all, with ibus-gnome3 however. no freeze happens without it. this also happens only once since gnome-shell is running. in other words, this issue is reproducible anytime if you do gnome-shell --replace after killing ibus and starting ibus again.

Version-Release number of selected component (if applicable):
ibus-1.3.99.20110419-10.fc15.x86_64
ibus-gnome3-1.3.99.20110419-10.fc15.x86_64
gnome-shell-3.0.2-4.fc15.x86_64

How reproducible:
only once since gnome-shell is brought up

Steps to Reproduce:
1. imsettings-switch none to ensure it's not relevant to this issue
2. ibus-daemon -r --xim
3. gnome-shell --replace
4. pkill ibus-daemon
5. do something on the desktop until seeing any messages of its termination.
  
Actual results:
gnome-shell freezes

Expected results:
shouldn't freeze

Additional info:
Comment 1 fujiwara 2011-07-13 23:28:11 EDT
I revised the restart logic:
https://github.com/fujiwarat/ibus-gjs/commit/d66fe81cb937f60dcb45379f04923f0ec09d3a57
Comment 2 Fedora Update System 2011-07-14 07:11:50 EDT
ibus-1.3.99.20110419-11.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-11.fc15
Comment 3 Fedora Update System 2011-07-14 21:25:21 EDT
Package ibus-1.3.99.20110419-11.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.3.99.20110419-11.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-11.fc15
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2011-07-18 18:46:00 EDT
ibus-1.3.99.20110419-11.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.