Bug 720896 - slapd repeatedly crashes in libssl3.so[110000+34000]
slapd repeatedly crashes in libssl3.so[110000+34000]
Status: CLOSED DUPLICATE of bug 701678
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
14
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jan Vcelak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-13 03:35 EDT by Frantisek Hanzlik
Modified: 2013-03-03 20:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 11:38:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frantisek Hanzlik 2011-07-13 03:35:00 EDT
Description of problem: Openldap 2.4.23 acting as authentication source for small server with cca 500 accounts. 
slapd crashes after several hours or days.
"/var/log/messages" contain items as these:

Jun  1 13:39:32 joko kernel: [97730.671115] slapd[26759]: segfault at 66fd40b4 ip 0012bbc8 sp b4dfddf0 error 6 in libssl3.so[110000+34000]
Jun 14 14:51:34 joko kernel: [133763.258801] slapd[10157]: segfault at 679d40b4 ip 00163d18 sp b4cfddf0 error 6 in libssl3.so[148000+34000]
Jun 20 09:53:30 joko kernel: [272223.479308] slapd[26602]: segfault at 67dd40b4 ip 00739d18 sp b51fcdf0 error 6 in libssl3.so[71e000+34000]
Jun 22 12:21:11 joko kernel: [453884.312551] slapd[23588]: segfault at 667d40b4 ip 00950d18 sp b53fedf0 error 6 in libssl3.so[935000+34000]
Jun 24 11:24:28 joko kernel: [19209.436001] slapd[1685]: segfault at 20 ip 00b84f4d sp b52fe7c4 error 4 in libpthread-2.13.so[b7d000+17000]
Jun 27 10:16:48 joko kernel: [274349.615288] slapd[2858]: segfault at 669d40b4 ip 00165d18 sp b54fedf0 error 6 in libssl3.so[14a000+34000]
Jul 11 12:12:21 joko kernel: [622636.907118] slapd[30524]: segfault at 675d40b4 ip 0047dd18 sp b58fedf0 error 6 in libssl3.so[462000+34000]


Version-Release number of selected component (if applicable):
openldap-2.4.23-10.fc14.i686

How reproducible:
probably not possible, seems as it crashes randomly.

Additional info:
Problem appears after upgrade to F14. Previous openldap-2.4.12@Fedora 10 at same machine was worked without any problems.
Comment 1 Rich Megginson 2011-07-13 11:09:21 EDT
Not sure where openldap dumps core.  You'll have to enable core dumps for setuid programs first:
 sysctl -w fs.suid_dumpable=1
then edit /etc/sysconfig/ldap and add this:
 ulimit -c unlimited
then install the openldap-debuginfo package
 debuginfo-install openldap
make sure this installs the nss-debuginfo package as well
Then
 service ldap restart
Then attempt to reproduce the problem

Not sure if this will work - if it does, not sure where the core file will be generated

Once you have a core dump, do this

gdb /usr/sbin/slapd /path/to/core.PID
(gdb) set logging on
(gdb) set logging file /tmp/slapd.bt.txt
(gdb) set logging redirect on
(gdb) thread apply all bt full
(gdb) set logging redirect off
(gdb) quit

EDIT /tmp/slapd.bt.txt TO REMOVE/OBSCURE ANY SENSITIVE DATA then attach /tmp/slapd.bt.txt to this bug as an attachment (text/plain)
Comment 2 Jan Vcelak 2011-07-18 03:59:27 EDT
(In reply to comment #1)
> Not sure where openldap dumps core.

The easiest way is to get ABRT installed and enabled. The core dumps are then collected in /var/spool/abrt
Comment 3 Need Real Name 2011-07-21 02:23:15 EDT
I have the same problem with openldap-2.4.23-15.el6 on rhel6.1
Comment 4 Rich Megginson 2011-07-25 12:27:27 EDT
(In reply to comment #3)
> I have the same problem with openldap-2.4.23-15.el6 on rhel6.1

Please install ABRT and generate a core dump, then a stack trace.
Comment 5 Need Real Name 2011-07-26 01:49:51 EDT
When slapd crashes I send the core dump because it crashes randomly.
Comment 6 Rich Megginson 2011-08-12 11:03:56 EDT
ping - any more crashes?
Comment 7 Wesley Harrell 2011-08-29 14:09:04 EDT
I was able to get a core dump on a rhel6 box and submitted it to an existing RHEL6 bug, here:  https://bugzilla.redhat.com/show_bug.cgi?id=709407#c8
Comment 8 Jan Vcelak 2011-09-12 11:38:29 EDT

*** This bug has been marked as a duplicate of bug 701678 ***

Note You need to log in before you can comment on or make changes to this bug.