Bug 72094 - RFE: FIPS replacement for resizing modern NTFS based Windows partitions
RFE: FIPS replacement for resizing modern NTFS based Windows partitions
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: distribution (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 23:22 EDT by Mike MacCana
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 23:22:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2002-08-20 23:22:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
Previously, the more popualr consumer versions of Windows used the FAT32
filesystem for storage. The FIPS utility on the Red Hat CD was a unsupported yet
capable system for resizing these partitions.

Nowdays both consumer and business versions of Windows use the NTFS filesystem
by default, which cannot be non-destructively resized by any existing Open
Source utility.

Having a free tool to assist Windows XP, 2000, and NT4 users resize their
partitions so they can dual boot will allow Windows users to still easily dual
boot Linux without additional software and expense, the same way they used to
with older versions of Windows.

I think adding NTFS support to parted may be an appropriate solution.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install a older version of consumer Windows (eg, 95, 98 Me)
2.Use FIPS to resize the partition and dual boot
2.Install the current version of consumer Windows, Windows XP 
2.Try and resize the partition to dual boot	

Additional info:
Comment 1 Preston Brown 2002-08-21 11:09:34 EDT
Resising NTFS is non-trivial.  Very non-trivial.  Spending time to implement 
such a feature would have very little return on investment.  Red Hat will 
incorporate such technology if the open source community develops it, but will 
not do so internally.
Comment 2 Mike MacCana 2002-08-21 18:21:02 EDT
Fair enough, thanks for the prompt answer anyway. I've since been told there is
indeed a good chance of this happening from the community sometime soon from the
Linux NTFS project.

Note You need to log in before you can comment on or make changes to this bug.