Bug 72097 - control-center theme installer deletes themes instead of installing them
control-center theme installer deletes themes instead of installing them
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: control-center (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-21 00:12 EDT by Shaun Carter
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 22:44:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shaun Carter 2002-08-21 00:12:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
When you try to drag and drop a folder onto the theme dialogue to install, the
folder being dragged is deleted.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.grab a theme tar and extract it
2.open the theme program from start here>preferences
3.drag the extracted folder into the installed theme window

	

Actual Results:  the theme manager displays the file install dialogue, the
folder is removed from the system.  Locate and find -name will not find the name
of the folder anywhere (just checking to see if it was moved and not deleted).

Expected Results:  The theme should be moved/installed to the proper directory
and the theme name should show up in the installed themes window.

Additional info:

tried installing the Amadeus and Aqua themes obtained from
sunshineinabag.co.uk/metacity/
Comment 1 Jonathan Blandford 2002-08-22 18:12:34 EDT
I can't duplicate the theme disappearing at all.  Can you take a look in
~/.themes to see if it actually installed it?  Note that the Amadeus theme isn't
a valid theme currently, as the theme format has changed.
Comment 2 Shaun Carter 2002-08-22 22:44:07 EDT
After logging out/logging in, I feel like an idiot.  The themes are now listed
and a locate and find -name both list the folders in ~/.themes.  Why did it take
logging out/in to get these to show up?  I have no idea.  Sorry.  I would still
like to know why it looked that way, but being that you can't dupe it, I know
how it is.
Comment 3 Havoc Pennington 2002-08-23 11:25:17 EDT
OK, closing for now. We'll keep an eye out for further reports.

Note You need to log in before you can comment on or make changes to this bug.