Bug 721010 - Ifup-aliases (ifconfig) becomes slower in proportion to the amount of networks with vlans
Summary: Ifup-aliases (ifconfig) becomes slower in proportion to the amount of network...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: initscripts Maintenance Team
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 773650 773651 773677 773696
TreeView+ depends on / blocked
 
Reported: 2011-07-13 14:30 UTC by Erez Shinan
Modified: 2015-04-16 11:36 UTC (History)
7 users (show)

Fixed In Version: initscripts-9.03.28-1.el6
Doc Type: Bug Fix
Doc Text:
In previous version of initscripts, ifup-aliases became slower with increasing number of vlans. This update replaces ifconfig in ip-aliases with ip.
Clone Of:
Environment:
Last Closed: 2012-06-20 13:02:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
reproducer (9.58 KB, text/x-python)
2011-07-13 14:30 UTC, Erez Shinan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0816 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2012-06-19 20:34:23 UTC

Description Erez Shinan 2011-07-13 14:30:37 UTC
Created attachment 512676 [details]
reproducer

Description of problem:
ifup on a bridge+vlan, when there are many bridges and vlans with it on the same nic, is very slow. The significant slow-down affects us and the entire software stack.

Version-Release number of selected component (if applicable):
initscripts-9.03.23-1.el6.x86_64

How reproducible:
Quite.

Steps to Reproduce:
1. Edit the constant "NIC" in the attached script to refer to an available network interface (e.g. NIC = "eth1")
2. Run the script with the number of network you want. (e.g. python makenetworks.py 100)
3. Read output
  
Actual results:
(an extract from the script)
Adding bridge  0 ... Starting ifups... ifups took 0.13 seconds
Adding bridge 10 ... Starting ifups... ifups took 0.18 seconds
Adding bridge 20 ... Starting ifups... ifups took 0.14 seconds
Adding bridge 30 ... Starting ifups... ifups took 0.16 seconds
Adding bridge 40 ... Starting ifups... ifups took 0.17 seconds
Adding bridge 50 ... Starting ifups... ifups took 0.45 seconds
Adding bridge 60 ... Starting ifups... ifups took 0.21 seconds
Adding bridge 70 ... Starting ifups... ifups took 0.22 seconds
Adding bridge 80 ... Starting ifups... ifups took 0.25 seconds
Adding bridge 90 ... Starting ifups... ifups took 0.28 seconds
Adding bridge 100 ... Starting ifups... ifups took 0.31 seconds
Adding bridge 110 ... Starting ifups... ifups took 0.35 seconds
Adding bridge 120 ... Starting ifups... ifups took 0.39 seconds
Adding bridge 130 ... Starting ifups... ifups took 0.43 seconds
Adding bridge 140 ... Starting ifups... ifups took 0.49 seconds
Adding bridge 150 ... Starting ifups... ifups took 0.53 seconds
Adding bridge 160 ... Starting ifups... ifups took 0.59 seconds
Adding bridge 170 ... Starting ifups... ifups took 0.65 seconds
Adding bridge 180 ... Starting ifups... ifups took 0.73 seconds
Adding bridge 190 ... Starting ifups... ifups took 0.80 seconds
Adding bridge 199 ... Starting ifups... ifups took 0.87 seconds

Expected results:
Umm constant performance?

Additional info:

Comment 1 Bill Nottingham 2012-01-05 21:42:11 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=588993#c18 may fix this. Needs more review and testing, though.

Comment 2 Bill Nottingham 2012-01-05 22:17:42 UTC
... never mind. That patch *will* fix your problem, but will break other things.

Comment 3 Bill Nottingham 2012-01-06 21:59:08 UTC
Please try https://bugzilla.redhat.com/attachment.cgi?id=551288 .

Comment 6 Lukáš Nykrýn 2012-03-22 11:03:21 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In previous version of initscripts, ifup-aliases became slower with increasing number of vlans. This update replaces ifconfig in ip-aliases with ip.

Comment 8 errata-xmlrpc 2012-06-20 13:02:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0816.html


Note You need to log in before you can comment on or make changes to this bug.