Bug 72103 - crash when turning free space of last disk into a Physical Volume
Summary: crash when turning free space of last disk into a Physical Volume
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-08-21 06:16 UTC by Alexandre Oliva
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 15:52:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2002-08-21 06:16:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724
Macintosh

Description of problem:
Editing the trailing free space of the second disk of a 2-disked system into an
LVM Physical Volume crashed anaconda, whereas doing so in the first disk worked.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Tell disk druid to preserve partitions.
2.Remove the last existing partition in each of the disks
3.Edit the free space in the first disk into an LVM PV
4.Try to do the same to the free space in the second disk
	

Actual Results:  3 succeeds, but 4 crashes anaconda when you click `ok' in the
partition edit window.

Expected Results:  3 and 4 should work just the same.

Additional info:

I'm trying to duplicate this with anaconda --test --method=nfs:/, but anaconda
bails out saying XF86Config doesn't take any arguments.

Comment 1 Michael Fulbright 2002-08-22 15:52:16 UTC
cd into /usr/lib/anaconda and type

PYTHONPATH=. /usr/sbin/anaconda --method=nfs:// --test

that should do it.

I have a two drive system and I don't see this issue, fwiw.

Did you go through the autopartitioning screen and say 'review ...'?


Comment 2 Alexandre Oliva 2002-08-22 21:48:33 UTC
Ok, I've tried to do it again, and failed.  It may be related with the raid
devices I had in those disks before, that are now LVM PVs, so I can no longer
get to the same situation I had.  Sorry.


Note You need to log in before you can comment on or make changes to this bug.