Bug 721033 - Openjdk font dependency
Openjdk font dependency
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: java-1.6.0-openjdk (Show other bugs)
5.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: jiri vanek
BaseOS QE - Apps
: Reopened
Depends On:
Blocks: 924830
  Show dependency treegraph
 
Reported: 2011-07-13 10:56 EDT by Danesh Mondegarian
Modified: 2014-02-21 10:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 924830 (view as bug list)
Environment:
Last Closed: 2013-04-23 01:49:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-6812 Major Closed Some messages in the installer are displayed in an unreadable font 2014-05-28 15:33:11 EDT

  None (edit)
Description Danesh Mondegarian 2011-07-13 10:56:44 EDT
Description of problem:

The package xorg-x11-fonts-Type1 seems to be missing on rhel5 when installed with the minimal installation setting.

This font seems crucial to rending the font for most java applications.

Exhibit a : https://issues.jboss.org/secure/attachment/12344881/Screenshot-1.png

That is an example of what the user see's if that package is missing.

Best solution would be to make this a dependency of sorts for openjdk.
Comment 1 Chris Lumens 2011-07-14 10:16:09 EDT
Please file dependency bugs against the component themselves, not anaconda.  anaconda doesn't have any specific information of what package depends on which.  Do you have any idea which bugzilla product the openjdk component is a part of so this can be reassigned correctly?
Comment 2 Deepak Bhole 2011-07-14 10:30:40 EDT
Re-assigning to proper component and owner.
Comment 3 jiri vanek 2011-07-15 02:29:51 EDT
It is funny that when testing i s included then BuildRequires alredy force xorg-x11-fonts-Type1. I think that it will be no harm to add  Requires xorg-x11-fonts-Type1 for all fedoras and rhels. Thank you for reporting such rarely occurred bug.
Comment 4 Danesh Mondegarian 2011-11-01 10:29:02 EDT
Any status update ?
Comment 5 jiri vanek 2012-01-27 13:42:16 EST
fixed in fedora for now.
Comment 6 Alex Szczuczko 2012-10-02 10:22:07 EDT
Has the fix made it into RHEL 5? Thanks.

Adding link to source JBoss JIRA issue.
Comment 7 jiri vanek 2012-10-15 05:27:57 EDT
This was never propagated to RHELs. 
As it in fedora for some time, it should be safe to add but it will need properly acked bugs.
Comment 15 jiri vanek 2013-03-25 13:13:03 EDT
Builds with fix of this were pushed to fedora.
if they will pass theirs usual QA, I'm for inclusion into next CPU for Rhel and for jdks 6
http://pkgs.fedoraproject.org/cgit/java-1.7.0-openjdk.git/commit/?id=89e2aea2f9880efd4ad773ef9dc566225c9ae9ef
Comment 16 JBoss JIRA Server 2014-02-21 10:59:31 EST
Thomas Hauser <thauser@redhat.com> updated the status of jira JBPAPP-6812 to Closed

Note You need to log in before you can comment on or make changes to this bug.