Bug 721053 - Delete All and Acknowledge All buttons on Recent Alerts portlet delete/acknowledge *all* alerts, not just the 5 most recent alerts displayed by the portlet
Delete All and Acknowledge All buttons on Recent Alerts portlet delete/acknow...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.1
Unspecified Unspecified
high Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Mike Foley
:
Depends On:
Blocks: rhq41 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-07-13 11:34 EDT by Ian Springer
Modified: 2013-08-05 20:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:20:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2011-07-13 11:34:13 EDT
This isn't intuitive. A user could easily accidentally delete or acknowledge all alerts in the system, when they only intended to delete or acknowledge the alerts shown by the portlet.
Comment 1 John Mazzitelli 2011-08-16 13:44:41 EDT
to easily solve this, we should hide the "all" buttons (delete all, acknowledge all). It is easy enough for the user to select the small number of rows shown here (typically only 5) and do a "delete" or "acknowledge". Otherwise, I think we would have to hack up some of the datasource code.
Comment 2 John Mazzitelli 2011-08-17 16:17:04 EDT
master commit 1a38866

the alert portlets no longer show the delete all and ack all buttons, so this problem goes away. This isn't too bad because the portlets are small anyway, and these two extra buttons with the long labels crowd the button area on the portlets and sometimes clip.

Do delete all or acknowledge all in the portlets, you just shift-click the first and last or you just control-click all of them. 

the normal alert history view still has the ability to delete all and ack all
Comment 3 Mike Foley 2011-08-18 10:03:41 EDT
verified 08/18 build
Comment 4 Mike Foley 2012-02-07 14:20:04 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.