This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 72108 - Anaconda crashed with unhandled exception for network GATEWAY
Anaconda crashed with unhandled exception for network GATEWAY
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
athlon Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-21 02:59 EDT by _spookymulder_
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-07 20:22:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description _spookymulder_ 2002-08-21 02:59:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)


Description of problem:
When attempting to install RedHat Limbo (Null) Beta 3 (7.4 or 8.0?) for I386, 
Anaconda fails with 
an unhandled exception.  

Bad: installation not possible

Version-Release number of selected component (if applicable):  7.3.94 


How reproducible:
Always

Steps to Reproduce:
1.Start a normal grafix installation (i used with option "linux reiserfs 
because of having backup hdds with reiserfs)
2.install Fullinstallation on HDE1 (format boot 
partition=ext2,/=reiserfs,swap=swap)
3.choose fullinstllation and install everything
4.after complete rpm installaton pc crash -->next step would be system 
configuration
	

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 778, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 631, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 68, in writeConfiguration
    id.write(instPath)
  File "/usr/lib/anaconda/instdata.py", line 106, in write
    self.network.write (instPath)
  File "/usr/lib/anaconda/network.py", line 279, in write
    ip = self.lookupHostname()
  File "/usr/lib/anaconda/network.py", line 186, in lookupHostname
    self.gateway)
  File "/usr/lib/anaconda/isys.py", line 379, in configNetDevice
    return _isys.confignetdevice(device, ip, netmask, gw)
TypeError: argument 4 must be string, not None

Local variables in innermost frame:

system configuration:
Tyan Tiger MPX
Dual Athlon MP 1600+
265MB DDR-Ram Kingston
DawiController Raid PCI
DawiControll SCSI Controller PCI
4x40GB Maxtor on Raid Controller
1x DVD Rom on secondary ide channel
Comment 1 Michael Fulbright 2002-08-22 11:31:31 EDT
Please give complete info on how you configured networking.
Comment 2 _spookymulder_ 2002-08-22 15:40:02 EDT
Hello,

i just entered on installation my local ip adress (192.168.1.10) the subnet
adress 255.255.255.0, my local computer name and the DNS IPs for my DSL Privder
(DNS 1 = 193.189.244.197 and DNS 2 = 193.189.244.205)

I tested today the textinstallation. that works fine - no crash with the the
same configuration. 

I did that changes at Red Hat 7.3 too and i had no problems.(i do this DNS Setup
because i need a dial on demand connection)

some more information here: I have a 10/100Mbit Hub and my computer is connected
to the hub and hub is connected to SDSL Modem.

cheers
Henrik
Comment 3 Michael Fulbright 2002-08-22 15:47:54 EDT
Did you install from CD or something else?
Comment 4 _spookymulder_ 2002-08-22 16:34:09 EDT
yes i installed from cd (checked md5sum on all 3 cds and all ok)

i have 3 cd drives 1x dvd rom (company=delta 12x40x)2x scsi cd-rcw recorder teac
58s (8x24x)

I installed from dvd rom.It is connected as Master on secondary channel.
Comment 5 Jared Smith 2002-08-24 15:15:52 EDT
I'm getting this same error on my installation... I'm installing from scratch on
a Dell Inspiron 3800 notebook w/no pcmcia cards installed (i.e. no network card).

I'm more than willing to help debug the problem if you can point me in the right
direction.
Comment 6 Preston Brown 2002-08-28 15:50:35 EDT
can you give us the contents of /tmp/netinfo file during installation (i.e. 
before the crash)?  You can switch to a command prompt by pressing 
Ctrl+Alt+F2, and switch back to the installer with Ctrl+Alt+F7.
Comment 7 Preston Brown 2002-08-28 15:51:51 EDT
neither of you are using DHCP, right?
Comment 8 Jay Turner 2002-09-04 08:27:38 EDT
Putting this in Needinfo, as we are awaiting feedback.
Comment 9 _spookymulder_ 2002-09-07 20:22:21 EDT
yes thats right.im not using dhcp
Comment 10 Michael Fulbright 2002-12-02 16:48:52 EST
I've duplicated this configuration and it worked fine for me.
Comment 11 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.