Bug 7211 - kickstart-file generated with mkkickstart bombs on install
kickstart-file generated with mkkickstart bombs on install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-21 14:45 EST by helmut katzgraber
Modified: 2015-01-07 18:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-29 10:58:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description helmut katzgraber 1999-11-21 14:45:55 EST
hello there.

i generated a simple kickstart file with mkkickstart on a redhat 6.1 box
(intel) and tried to use it to install another machine. the file looks as
follows

lang en_US
cdrom
install
%packages
LIST_OF_PACKAGES
%post

i took the default boot image from the cd, removed a message and placed the
ks.cfg there. after boot, i typed at the prompt

	linux ks=floppy

when the install goes to the point right after /sbin/loader, it bombs with
some cryptic error messages (pythonian) and halts thr system.

any suggestions?

cheers, helmut.
Comment 1 Jay Turner 1999-11-22 09:27:59 EST
Please send the text of the error message which is getting generated and we
should be able to tell you what is happening.  The file that you provided looks
fine to me, so I am betting that something in your list of packages is causing
the problem you are seeing.
Comment 2 helmut katzgraber 1999-11-22 16:27:59 EST
hi there.

i wont be able to make another install until next weekend due to the fact that
the machines are being used by the users at the moment. in the meantime i can
send you the complete kickstart file. let me know if you want the exact error
message output. it was something about python errors.

here's the ks.cfg:

lang en_US
cdrom
install
mouse ps/2 --emulthree
%packages
setup
filesystem
basesystem
ldconfig
AfterStep
AfterStep-APPS
AnotherLevel
ElectricFence
ImageMagick
ImageMagick-devel
glibc
shadow-utils
mktemp
termcap
libtermcap
bash
MAKEDEV
ncurses
info
ORBit
SysVinit
WindowMaker
X11R6-contrib
chkconfig
fileutils
utempter
XFree86
mingetty
gawk
sed
e2fsprogs
console-tools
procps
vixie-cron
modutils
logrotate
xv
psmisc
grep
tcsh
initscripts
XFree86-libs
XFree86-xfs
chkfontpath
XFree86-75dpi-fonts
XFree86-SVGA
Xaw3d
Xconfigurator
apmd
arpwatch
ash
at
audiofile
authconfig
autoconf
automake
bc
bdflush
binutils
bison
byacc
bzip2
cdp
compat-glibc
compat-libs
control-panel
rmt
cpio
cpp
cracklib
cracklib-dicts
crontabs
cvs
textutils
dev
dev86
dialog
diffutils
ed
egcs
egcs-c++
egcs-g77
egcs-objc
eject
elm
emacs
emacs-X11
emacs-el
emacs-leim
emacs-nox
enscript
esound
etcskel
expect
fetchmail
fetchmailconf
file
findutils
finger
fnlib
fortune-mod
freetype
ftp
fvwm
fvwm2
fvwm2-icons
gd
gdb
gdbm
getty_ps
ghostscript
ghostscript-fonts
gimp
gimp-data-extras
gimp-libgimp
glib
glib10
gmp
gnome-audio
gnome-libs
gnuchess
gnuplot
gpm
gqview
groff
gtk+
gtk+10
gtk-engines
guile
gv
gzip
hdparm
ical
imlib
imlib-cfgeditor
indent
indexhtml
ipchains
isapnptools
ispell
kbdconfig
kernel
kernel-doc
kernel-headers
kernel-pcmcia-cs
kernel-source
kernelcfg
kudzu
ld.so
less
libPropList
libc
libghttp
libglade
libgr
libgr-progs
libgtop
libjpeg
libpcap
libpng
libstdc++
libtiff
libtool
libungif
libxml
libxml10
lilo
pwdb
pam
sh-utils
redhat-release
linuxconf
losetup
sysklogd
lsof
lynx
m4
macutils
mailcap
mailx
make
man
man-pages
mawk
metamail
minicom
mkbootdisk
mkinitrd
mkkickstart
mkxauth
mount
mouseconfig
mpage
mt-st
mtools
ncompress
net-tools
netcfg
netkit-base
netscape-common
netscape-communicator
netscape-navigator
newt
ntsysv
passwd
patch
pciutils
perl
pidentd
pine
portmap
procmail
pump
pygtk
python
python-tools
pythonlib
quota
raidtools
rcs
rdist
readline
redhat-logos
rootfiles
routed
rpm
rpmfind
rsh
rxvt
sash
screen
sendmail
sendmail-cf
sendmail-doc
setconsole
setserial
setuptool
sharutils
slang
slocate
stat
symlinks
talk
tar
tcl
tclx
tcp_wrappers
tcpdump
telnet
tetex
tetex-afm
tetex-doc
tetex-dvilj
tetex-dvips
tetex-fonts
tetex-latex
tetex-xdvi
time
timeconfig
timetool
tix
tk
tkinter
tksysv
tmpwatch
traceroute
transfig
tree
umb-scheme
units
unzip
urw-fonts
usermode
util-linux
uucp
vim-X11
vim-common
vim-enhanced
vim-minimal
which
wmakerconf
wmconfig
words
xanim
xbill
xboing
xfig
xinitrc
xloadimage
xlockmore
tripwire
xpaint
xpdf
xpm
xscreensaver
xsri
xtrojka
xxgdb
zip
zlib
bind-utils
XFree86-devel
glibc-profile
libelf
glibc-devel
glib-devel
netdate
logcheck
mpeg_play
LPRng
%post
Comment 3 Jay Turner 1999-11-29 10:58:59 EST
Your mouse line should be "mouse genericps/2 --emulthree"  That should solve the
problem.  Reopen this bug if it down not!

Note You need to log in before you can comment on or make changes to this bug.