Bug 72128 - Service ntp needs to start *after* named
Service ntp needs to start *after* named
Status: CLOSED DUPLICATE of bug 46464
Product: Red Hat Linux
Classification: Retired
Component: ntp (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
n/a
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-21 06:39 EDT by Mike Tubby
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 06:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Tubby 2002-08-21 06:39:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
The network time protocol (ntp) fails to start up correctly on a machine that 
also runs a local name server (named) if the 'step tickers' are specified by 
hostnames (fqdn).

This is because the default behaviour on RH installations is to start ntp 
in /etc/rc.d/rc3.d as S26ntp and named as S55named.

For ntp to be able to use hostnames (in both /etc/ntp/step-tickers) and 
in /etc/ntp.conf "server xxxxx" entries the name server needs to be running 
*before* NTP is started.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install both ntp and named as a local name server
2. Set the machine up to do local name resolutions /etc/resolv.conf 
with "nameserver 127.0.0.1"
3. Set ntp up to use named hosts for step tickers, eg. edit /etc/ntp/step-
tickers put in something like "ntp.demon.co.uk", etc.
4. Ensure both services are configured to run at start up "chkconfig named 
on"; "chkconfig ntpd on";
5. Restart the machine

	

Actual Results:  When the machine changes to run-level 3 and executes S26ntp it 
will
hang for a period, and then fail where it says:

Ntpd: Synchronizing with time server: [FAILED]

Because it can't resolve the name of the step-ticker clock




Expected Results:  Ntpd: Synchronizing with time server: [SUCCESS]

Additional info:

It is legitimate to use hostnames in /etc/ntp/step-tickers - for this to work 
the machine *must* be able to resolve names... in otherwords, this can only 
work if NTP is started *after* named.

Suggestion is that NTP is moved later in the startup sequence to something like 
S57ntp so that the name server is always available.

Please fix in next issue of init-scripts. Its a real pain to keep having to 
move NTP around.
Comment 1 Harald Hoyer 2002-08-21 07:53:45 EDT

*** This bug has been marked as a duplicate of 46464 ***

Note You need to log in before you can comment on or make changes to this bug.