Bug 72133 - php 4.1.2 bugfix/upgrade fails to install due to missing dependencies
php 4.1.2 bugfix/upgrade fails to install due to missing dependencies
Status: CLOSED DUPLICATE of bug 72007
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-21 07:29 EDT by David Jansen
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 07:29:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2002-08-21 07:29:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
The recent bugfix/upgrade of the php packages to version 4.1.2 refuses to
install; suddenly php has dependencies on a lot ov 'devel' packages, but our
webservers are not installed as development machines.There are also dependencies
on postgresql, krb5, imap, unixODBC and ucd-snmp-utils which were not there in
the previous versions of php, so basically I need to upgrade all of our
webservers to have this patch installed, besides, I don't want to have services
like postgresql or imap on a machine that should be a dedicated web server. Is
there any other way to get the job done?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -Uv php-4.1.2-7.2.3.i386.rpm php-mysql-4.1.2-7.2.3.i386.rpm
(php and php-mysql were the only packages installed on our webserver)
	

Actual Results:  Output of the command:
error: failed dependencies:
        bzip2-devel >= 1.0 is needed by php-4.1.2-7.2.3
        curl-devel >= 7.8 is needed by php-4.1.2-7.2.3
        db3-devel is needed by php-4.1.2-7.2.3
        expat-devel is needed by php-4.1.2-7.2.3
        freetype-devel >= 2.0.0 is needed by php-4.1.2-7.2.3
        gd-devel is needed by php-4.1.2-7.2.3
        gdbm-devel is needed by php-4.1.2-7.2.3
        gmp-devel is needed by php-4.1.2-7.2.3
        imap >= 2000-9 is needed by php-4.1.2-7.2.3
        imap-devel >= 2000-9 is needed by php-4.1.2-7.2.3
        krb5-devel is needed by php-4.1.2-7.2.3
        libjpeg-devel is needed by php-4.1.2-7.2.3
        libpng-devel is needed by php-4.1.2-7.2.3
        libxml2-devel >= 2.4 is needed by php-4.1.2-7.2.3
        mm-devel is needed by php-4.1.2-7.2.3
        mysql-devel is needed by php-4.1.2-7.2.3
        openssl-devel is needed by php-4.1.2-7.2.3
        pam-devel is needed by php-4.1.2-7.2.3
        postgresql is needed by php-4.1.2-7.2.3
        postgresql-devel is needed by php-4.1.2-7.2.3
        pspell-devel is needed by php-4.1.2-7.2.3
        ucd-snmp-utils is needed by php-4.1.2-7.2.3
        ucd-snmp-devel is needed by php-4.1.2-7.2.3
        unixODBC is needed by php-4.1.2-7.2.3
        unixODBC-devel is needed by php-4.1.2-7.2.3
        zlib-devel is needed by php-4.1.2-7.2.3

Expected Results:  it should have applied the update; I checked on the errata
pages and there is no mention of specific requirements

Additional info:
Comment 1 James Manning 2002-08-21 11:24:44 EDT

*** This bug has been marked as a duplicate of 72007 ***

Note You need to log in before you can comment on or make changes to this bug.