Bug 721354 - Provide native systemd unit file
Provide native systemd unit file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: exim (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd 751869
  Show dependency treegraph
 
Reported: 2011-07-14 07:10 EDT by Jóhann B. Guðmundsson
Modified: 2015-01-06 14:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-02 05:08:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New /etc/sysconfig/exim (24 bytes, text/plain)
2011-07-14 07:11 EDT, Jóhann B. Guðmundsson
no flags Details
Exim Cert generator (973 bytes, text/plain)
2011-07-14 07:12 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file exim (340 bytes, text/plain)
2011-07-14 07:14 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file clamd.exim (355 bytes, text/plain)
2011-07-14 14:45 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file clamd.exim socket (127 bytes, text/plain)
2011-07-14 14:46 EDT, Jóhann B. Guðmundsson
no flags Details
Spec file patch (3.16 KB, text/plain)
2011-07-14 15:11 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for exim (278 bytes, text/plain)
2011-12-14 16:52 EST, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for clamd.exim (292 bytes, text/plain)
2011-12-14 16:56 EST, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for clamd exim (245 bytes, text/plain)
2012-01-05 14:08 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-07-14 07:10:29 EDT
Description of problem:

https://fedoraproject.org/wiki/Features/SysVtoSystemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-07-14 07:11:51 EDT
Created attachment 512859 [details]
New /etc/sysconfig/exim
Comment 2 Jóhann B. Guðmundsson 2011-07-14 07:12:31 EDT
Created attachment 512860 [details]
Exim Cert generator
Comment 3 Jóhann B. Guðmundsson 2011-07-14 07:14:24 EDT
Created attachment 512862 [details]
Native systemd service file exim
Comment 4 Jóhann B. Guðmundsson 2011-07-14 14:45:24 EDT
Created attachment 513244 [details]
Native systemd service file clamd.exim
Comment 5 Jóhann B. Guðmundsson 2011-07-14 14:46:21 EDT
Created attachment 513245 [details]
Native systemd service file clamd.exim socket
Comment 7 Jóhann B. Guðmundsson 2011-07-14 15:11:01 EDT
Created attachment 513248 [details]
Spec file patch

I think I got this one right but you might consider adding a tmpfile for clamd.exim
Comment 8 Jóhann B. Guðmundsson 2011-12-14 16:52:17 EST
Created attachment 546918 [details]
Native systemd service file for exim

Updated to reflect the current status in systemd

Dropped /etc/sysconfig file since it's Red Hat specific and users really should copy the unit file to /etc/systemd/system and add/edit any option to it there..
Comment 9 Jóhann B. Guðmundsson 2011-12-14 16:56:06 EST
Created attachment 546920 [details]
Native systemd service file for clamd.exim

Updated to reflect the current state of systemd drop /etc/sysconfig environment file
Comment 10 Jóhann B. Guðmundsson 2011-12-14 16:56:32 EST
Ping
Comment 11 Jaroslav Škarvada 2011-12-15 07:57:53 EST
Hi Jóhann,

thanks for your help. I became exim co-maintainer. I will give it deeper look and testing, ETA probably one week.
Comment 12 Jóhann B. Guðmundsson 2012-01-05 14:08:58 EST
Created attachment 550994 [details]
Native systemd service file for clamd exim

Apparently the socket unit should not be created...
Comment 13 Jaroslav Škarvada 2012-02-06 05:06:10 EST
It passed my simple testing and I pushed it with some mods. I think there is a room for improvement regarding the clamav support and we could unify this across other clamav enabled packages. I would like to hear opinions from other maintainers, thus some BZ tracker would be probably helpful for this.

Note You need to log in before you can comment on or make changes to this bug.