Bug 721385 - Deltacloudd cannot start because of old version of thin
Summary: Deltacloudd cannot start because of old version of thin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-thin
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Fojtik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-14 13:22 UTC by Jozef Zigmund
Modified: 2011-08-31 01:42 UTC (History)
1 user (show)

Fixed In Version: rubygem-thin-1.2.11-10.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-15 01:21:12 UTC
Type: ---


Attachments (Terms of Use)

Description Jozef Zigmund 2011-07-14 13:22:26 UTC
Description of problem:

Deltacloudd start with this error:

Starting Deltacloud API :: mock :: http://localhost:3001/api
 
 
13:57:28 - Jzigmund Launched
>> Thin web server (v1.2.8 codename Black Keys)
>> Debugging ON
>> Maximum connections set to 1024
>> Listening on localhost:3001, CTRL+C to stop
Watching /usr/share/deltacloud-core/**/*.{rb,js,css,erb}
/usr/lib/ruby/gems/1.8/gems/thin-1.2.8/lib/thin/request.rb:52:in `initialize': uninitialized constant Thin::HttpParser (NameError)
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.8/lib/thin/connection.rb:35:in `new'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.8/lib/thin/connection.rb:35:in `post_init'
	from /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/em/connection.rb:45:in `new'
	from /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/em/connection.rb:36:in `instance_eval'
	from /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/em/connection.rb:36:in `new'
	from /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1430:in `event_callback'
	from /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `run_machine'
	from /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `run'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.8/lib/thin/backends/base.rb:61:in `start'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.8/lib/thin/server.rb:159:in `start'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.8/lib/thin/controllers/controller.rb:86:in `start'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.8/lib/thin/runner.rb:185:in `send'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.8/lib/thin/runner.rb:185:in `run_command'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.8/lib/thin/runner.rb:151:in `run!'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.8/bin/thin:6
	from /usr/bin/thin:19:in `load'
	from /usr/bin/thin:19

Please update rubygem-thin.

Comment 1 Fedora Update System 2011-07-14 13:52:55 UTC
rubygem-thin-1.2.11-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rubygem-thin-1.2.11-1.fc14

Comment 2 Fedora Update System 2011-07-14 16:25:07 UTC
rubygem-thin-1.2.11-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rubygem-thin-1.2.11-5.fc14

Comment 3 Fedora Update System 2011-07-14 17:04:53 UTC
rubygem-thin-1.2.11-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rubygem-thin-1.2.11-8.fc14

Comment 4 Fedora Update System 2011-07-15 01:21:08 UTC
rubygem-thin-1.2.11-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2011-08-18 20:16:05 UTC
rubygem-thin-1.2.11-10.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rubygem-thin-1.2.11-10.fc14

Comment 6 Fedora Update System 2011-08-31 01:42:11 UTC
rubygem-thin-1.2.11-10.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.