Bug 72151 - key repitition seems broken
key repitition seems broken
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-08-21 11:28 EDT by Taco Witte
Modified: 2007-04-18 12:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-12-15 11:00:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Taco Witte 2002-08-21 11:28:11 EDT
(Sorry, I don't know in which component this belongs. It's system-wide, althougj
it only applies to X, not to console mode.)

Description of Problem:
Key repitition doesn't work, although it's enabled in Preferences|Keyboard. When
holding down a key, only one character appears. Changing the delay or speed, or
disabling it, doesn't help. This only seems to apply to X, when using the
console it works.

Version-Release number of selected component (if applicable):
(null), no updates

How Reproducible:
Under X, always. (it appears)

Steps to Reproduce:
1. None, should be enabled by default.

Actual Results:
Holding down a key doesn't repeat the key. Only one character appears.

Expected Results:
After 0.5 second or so, more repitition of the same key.

Additional Information:
My keyboard is configured as US International (could have something to do with
dead keys??)
Comment 1 Mike A. Harris 2002-08-22 03:42:34 EDT
Nothing has changed in X that would cause such behaviour so this
is highly unlikely to be an X bug.

Key repeat works fine for me on all of my machines.

You'll have to provide more information on what hardware you are using,
and what specific steps you have tried doing.
Comment 2 Taco Witte 2002-08-22 03:54:23 EDT
>Key repeat works fine for me on all of my machines.

It currently works! There's probably some instability, but I really don't know
why it didn't work (probably it doesn't work in some circumstances, which
existed yesterday when I tried it, but which don't exist currently; sorry!).

>You'll have to provide more information on what hardware you are using,
>and what specific steps you have tried doing.

My PS/2 keyboard is configured as US International, and I tried to change the
key repitition using Preferences|Keyboard (nothing else). I tried everything in
that program I could think of, but it wouldn't change a thing. (Now it works.)

I'm afraid I can't tell why it didn't work (there are no logical circumstances,
or changes since yesterday). Maybe the best solution would be to resolve this
bug as NOTABUG..

(Side issue: the scroll bar in that same preferences program for the delay works
exactly the other way around as is indicated.)
Comment 3 Christopher Blizzard 2002-08-22 13:10:32 EDT
joe has seen this with gnome2 without our beta so it's probably a gnome bug.

[13:00:35] <joe> I've seen it a couple of times in the g2 snaps and in xd2
snaps, so it's not a red hat-only problem
[13:08:20] <joe> Well, I don't know much about the problem; it's very sporadic.
 Sometimes it happens on login, sometimes shortly after an unsuspend
[13:08:42] <joe> Doing an "xset r on" or "xset r rate ..." doesn't work
[13:08:47] <joe> Jody told me to try the following, though:
[13:08:54] <joe> 12:13 < jody> 1) kill settings deamon
[13:08:54] <joe> 12:14 < jody> 2) xset r rate 500 50
[13:08:54] <joe> 12:14 < jody> 3) xset -q
[13:08:54] <joe> 12:14 < jody> a) Does it keep the 500 50 ?
[13:08:54] <joe> 12:14 < jody> b) Do you get any repeat ?
[13:09:05] <joe> but I haven't been able to try it out because it's working for
me now, and I need to get work done. :)
Comment 4 Jonathan Blandford 2002-08-22 13:32:40 EDT
I've seen rumors of X screwing up the repeat rate after an unsuspension.  Are
either of these machines laptops?
Comment 5 Christopher Blizzard 2002-08-22 13:53:20 EDT
[13:52:43] <joe> blizzard: just on my laptop
Comment 6 Taco Witte 2002-08-22 15:28:59 EDT
My machine isn't a laptop. If that's interesting, I have a SiS 730S mainboard
(the AMD variant of 730). Please ask for specific information if you can use it.
Comment 7 Joe Shaw 2002-08-26 11:19:18 EDT
So, I've seen the behavior a bit more.  I'm still not totally sure if suspending
is what's causing the problem.

If I am having the problem and I log out, I don't see the problem in gdm or my
ssh-askpass-gnome, but it does show up after I log in.

If I kill the X server, though, and log back in, I don't see the problem (or at
least, have not yet).  It usually happens then after I suspend, and
occassionally when I switch between the internal display and the external VGA.

"xset r" doesn't seem to ever work, nor does killing gnome-settings-daemon.
Comment 8 Joe Shaw 2002-08-26 11:24:07 EDT
Oh, I should note that this first happened when I installed null and uninstalled
it because of this.  But it happens for me now in 7.3, since I started running
GNOME 2 on it.  Previously I ran 7.2 on this machine with the daily gnome 2
snaps (as recently as about 3 weeks ago) and never saw any problems.  I suspect
it may be a change between XFree 4.1 and 4.2.
Comment 9 LI Xianfeng 2002-12-15 10:07:28 EST
Yes, I also found the power-saving configuration in my BIOS relates to this
problem. It was set to suspend after 15 minutes without using. Then after I 
come back. The key repeat is disabled. Later I disabled suspending my machine
in BIOS setting. Then this problem disappeared.

BTW, previously I ran Redhat 7.2 and this problem did not exist. Only after I
upgraded/reinstalled to 7.3/8.0, this problem crept into my machine.
Comment 10 Mike A. Harris 2002-12-15 11:00:25 EST
You've indicated changing a BIOS setting makes the problem go away, so I
consider this a weirdo hardware/BIOS issue.  It is not going to be
reproduceable on any hardware that I have available to me in any case,
and so wether it is a hardware bug, BIOS bug, or an XFree86 bug in the end,
there is virtually nothing I can do about it.  In any case it most certainly
isn't a Red Hat specific problem, and since you've worked around the issue,
I'm closing this WONTFIX.

If the problem recurs or you would like someone to investigate it further
I suggest reporting it directly to xfree86@xfree86.org so that the upstream
developers and maintainers are aware of the problem and if someone has the
hardware on hand they can investigate.

Note You need to log in before you can comment on or make changes to this bug.