Bug 72170 - bad error: "Failed to read directory /mnt/source"
Summary: bad error: "Failed to read directory /mnt/source"
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-21 17:17 UTC by John Reiser
Modified: 2007-04-18 16:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-24 23:04:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Reiser 2002-08-21 17:17:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
During a text mode install using .iso images from hard disk on another
partition, I get an "Error: Failed to read directory /mnt/source: No such file
or directory [OK]". Installation succeeds after OKing the Error, so it should be
just a warning instead.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install "(null)" beta from hard disk using .iso images on another partition.
 Floppy boot "linux askmethod", then choose hard disk.
2. Source directory has only the first 3 .iso images.
3.
	

Actual Results:  "Error: Failed to read directory /mnt/source: No such file or
directory [OK]"; but OKing the Error gives an installation which is apparently good.

Expected Results:  Only a warning message, instead of the Error.  Or, an
explanation of how the installation will be impaired if I proceed.

Additional info:

Comment 1 Michael Fulbright 2002-08-22 16:14:38 UTC
At what point do you get this error? I went all the way to the partitioning
screen and did not see it.

Comment 2 John Reiser 2002-08-22 18:07:42 UTC
I reproduced it again:
  floppy boot.img
  linux askmethod
  English language
  us keyboard
  hard drive install
  partition hda7, directory "null"
     Error: Failed to read directory /mnt/source:
     No such file or directory
  OK (dismiss error)
  Running anaconda, the RedHat ...

The installation target partion is /dev/hda3, a primary partition;
but that has not been communicated to the installer yet.
The .iso images are on /dev/hda7, a logical partition in an Extended partition.

Comment 3 Need Real Name 2002-09-24 23:04:03 UTC
I am having the very same issue on a toshiba portege 3490ct, I have tried ftp,
nfs, http and finally from the hda2 on the machine. Exact same error and
behavour when I try and install fro, the HD.

I can consistantly reproduce it and I haven't found a way around it as yet.

Tholmes@speakeasy.org

Comment 4 Michael Fulbright 2002-09-27 19:52:27 UTC
I have not had any problems with HD iso based installs.


Note You need to log in before you can comment on or make changes to this bug.