Bug 72173 - Installer crashed on a minimal install
Summary: Installer crashed on a minimal install
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-08-21 17:28 UTC by Peter van Egdom
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 19:51:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda crashdump text (66.12 KB, text/plain)
2002-08-21 17:29 UTC, Peter van Egdom
no flags Details

Description Peter van Egdom 2002-08-21 17:28:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
On one of the computers at my disposal for testing the Red Hat Linux
'null'-beta, I had a crash in Anaconda.

(ps.. the installation CD's PASSed the mediacheck).

I did a "minimal" installation on that computer and just after it was 
finished with installing the last package it crashed.

Anaconda offered me to make a crashdump to floppy, which I did.
(see attachment)

Unfortunately, due to lack of time, I cannot try to reproduce it
in the couple of days, I will try in the coming weekend again.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try (yet)

Steps to Reproduce:
1. Install Red Hat Linux
2. Select "Minimal Install" on Package selection screen
3.
	

Actual Results:  Anaconda crashed right after copying packages to the
harddisk.

Expected Results:  Anaconda should continue right after copying packages 
to the harddisk.

Additional info:

- Red Hat Linux 'null' beta.

Comment 1 Peter van Egdom 2002-08-21 17:29:26 UTC
Created attachment 71964 [details]
Anaconda crashdump text

Comment 2 Miguel Armas 2002-08-21 20:25:29 UTC
Anaconda crashes not only on minimal installation.   
In all the tests I've done it crashes everytime you do an  
installation where you only use one CD.  
 
I've done an installation from various CD and it works,  
then I move the needed packages to the first CD, do the  
genhdlist and try to install with the new CD: it crashes.  
Maybe someone forgot to kill a process before trying to  
unmount /mnt/source?

Comment 3 Michael Fulbright 2002-08-22 15:41:10 UTC
Jeremy I thought this wouldnt happen.

Comment 4 Jeremy Katz 2002-08-22 19:51:45 UTC
Aha, I see what's going on.  We were trying to unmount the CD when done
installing packages now so that you can eject the CD on the last screen.  This
is fine on multi-CD installs, but not on single CD installs because we don't do
the changeloop hack there.  Changed so that failing to unmount in filesDone()
isn't fatal and we just have the old behavior for single CD installs.

Comment 5 Ben Levenson 2002-09-03 21:23:18 UTC
fix verified.


Note You need to log in before you can comment on or make changes to this bug.