Bug 72185 - ICE in build_abbrev_table when -O2 and -g switchs are used
ICE in build_abbrev_table when -O2 and -g switchs are used
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-21 15:47 EDT by James Antill
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 13:57:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2002-08-21 15:47:23 EDT
Description of Problem:
 When compiling with gcc3 and -g, compiler stops compiling due to ICE.

Version-Release number of selected component (if applicable):
gcc3-3.1-5

How Reproducible:
 Always

Steps to Reproduce:
1. Get tarball from http://www.and.org/gcc3-ICE-wchar.tar.bz2
2. unpack tarball
3. run ./run.sh

Actual Results:
gcc has ICE

Expected Results:
shiny happy compile

Additional Information:
Note that passing -DUSE_RESTRICTED_HEADERS to gcc generates the ICE in a
different system header. Also note that commenting out VSTR_AUTOCONF_HAVE_INLINE
from the vstr-conf.h file will stop the ICE.
Comment 1 Richard Henderson 2004-10-02 22:56:09 EDT
Test case no longer exists.
Comment 2 James Antill 2004-10-03 13:45:15 EDT
 Shocking and after only 2 years. I've put it back at the above URL.
Comment 3 Vladimir Makarov 2004-10-05 13:57:07 EDT
  I've just the test with the current redhat gcc-3.3 branch.  It seems
that the bug was fixed.  So I am closing the case.

Note You need to log in before you can comment on or make changes to this bug.