Bug 72203 - anaconda unhandled exception during install
anaconda unhandled exception during install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i586 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-21 18:22 EDT by Lewis Doll
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 12:06:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda unhandled exception dump file (text) (57.81 KB, text/plain)
2002-08-21 18:24 EDT, Lewis Doll
no flags Details

  None (edit)
Description Lewis Doll 2002-08-21 18:22:07 EDT
Description of Problem: anaconda gets unhandled exception and aborts to window
requesting the filing of a detailed bug report.  Happens while resolving package
dependencies before actually installing software on hard disk.  Disks 
partitioned and formatted just prior to exception step.


Version-Release number of selected component (if applicable):
Whatever is on the 7.3 install cd in the personal version kit.

How Reproducible:
Attempt to install 7.3 following custom path with manual partitioning of two
drives.

Steps to Reproduce:
1. boot from floppy (boot.img)  
2. follow install custom path through disk partition with Druid, X config,
either selected packages or everything list (firewall disabled, no network 
connected to machine but interface present, through final panel that says 
to click on next to install.
3. Watch format of /, /home, /var and /usr followed by resolving dependancies
between packages, which gets unhandled exception  (dump file attached 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Lewis Doll 2002-08-21 18:24:13 EDT
Created attachment 72084 [details]
anaconda unhandled exception dump file (text)
Comment 2 Michael Fulbright 2002-08-22 12:16:26 EDT
Have you tested your CDs?

  htttp://people.redhat.com/~msf/mediacheck.html
Comment 3 Lewis Doll 2002-08-22 16:31:06 EDT
I ran mediacheck and it claimed that there was no checksum information on the cd
so it could not do the checksum.  This was a shrinkwrapped package with seals
intact.  I registered the product yesterday.  I purchased it Tuesday.  

Do I have to obtain the checksum info from a separate source (like tripwire)?  
I cannot read the man page as I have not been able to get the system to install.

I bought 7.3 and the RHCE study guide to prepare to take the test next month.  
If this is not resolved quickly, I will return it as defective to the point of 
purchase.  

I tried doing the default workstation install, let it do the partitioning, and
only added KDE and software development packages and it faild the same.  I then
tried without the software development package and it went past the original 
stopping point only do fail while trying to install glibc due to media error or 
lack of space.  I am getting ready to try again using ext2 instead of ext3 file 
systems to see if it is actually running out of journal space on the file 
system (too much changing at once overruns the journal space before it can 
flush changes out).
Comment 4 Lewis Doll 2002-08-22 17:37:09 EDT
To be more specific on mediacheck results:
Disk    Outcome
  1     "Unable to read the disc checksum from primary volume descriptor. This
         probably means the disk was created without the adding the checksum."

  2     Checks OK

  3     Checks OK

  4     No "Valhalla 7.3 Disc[N]" label, but checks ok

  5     Checks OK

  6     No checksum info (same as 1)

  7     No checksum info (Star Office)

  8     No checksum info
Comment 5 Lewis Doll 2002-08-23 11:59:27 EDT
File system type made no difference.  I got out my old Mandrake 6.0 package and
installed it from scratch just fine.  I think you owe me new CDs and three days 
of my time back for shipping defective products.  Of course I will settle for
new CDs shipped overnight at your expence with prepaid return package for the 
defective CDs (assuming you want the bad ones back....).
Comment 6 Lewis Doll 2002-08-23 12:05:54 EDT
This is just note it is a pentium system.  Only 36 days left until the RHCE 
exam in Phoenix, so please resolve quickly!  It is hard to study without the OS 
to play with.
Comment 7 Lewis Doll 2002-08-28 13:40:59 EDT
Received replacement CD set.  First 5 discs checked ok.  Started install and 
was well into process when it flashed a message that a file was missing or a 
package was corrupt.  I rechecked disc 1 and it now failed.  I examined the
CD drive and noted that the disc had started to slip on the hub.  This would 
cause the data clock to loose synch.  I made and placed a shim on disc 1 and
rechecked it and it checked ok, as well as now showed "Valhalla disc 1" label
in check window.  Restarted install and was able to complete the install.  I 
will not speculate on why your CDs slip and other vendors CDs do not.  The
shim solves the problem.

Note You need to log in before you can comment on or make changes to this bug.