Bug 72209 - firstboot setup agent contains untranslated messages in zh_TW locale
firstboot setup agent contains untranslated messages in zh_TW locale
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: gtk2 (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-21 19:07 EDT by Ben Wu
Modified: 2013-01-10 16:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 21:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gtk+ 2.0 zh_TW.po file (99.61 KB, text/plain)
2002-08-22 00:11 EDT, Ben Wu
no flags Details

  None (edit)
Description Ben Wu 2002-08-21 19:07:15 EDT
Description of Problem:
In firstboot Setup Agent, there are some untranslated messages, such as "Back"
and "Forward" buttons. They are not in the PO file. My default LANG is zh_TW.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. First time boots up with LANG=zh_TW
2. Display firstboot Setup Agent
3. 

Actual Results:
Shows some untranslated messages

Expected Results:
Should include them in the PO file 

Additional Information:
Those untranslated messages are not in the newly updated PO file.
Comment 1 Brent Fox 2002-08-21 19:29:34 EDT
No, those are stock gtk buttons and should be translated in the gtk20.po files.
 If you were to run another program that uses "Forward" and "Back" buttons such
as up2date in zh_TW, you would see the same thing.  Other gtk stock buttons such
as "Cancel" and "Quit" are translated.  Also, the buttons are translated in
zh_CN, but some translations are missing from zh_TW. 

Changing component to gtk2.
Comment 2 Ben Wu 2002-08-21 19:38:03 EDT
Where can I get gtk20.po file? I can do the missing translation for this file
and also whom should I send it to after I am done?
Comment 3 Havoc Pennington 2002-08-21 20:01:58 EDT
hpwu, the gtk files should have been translated in time for the gnome 2.0.1
upstream release and submitted to Abel Cheung (see
http://developer.gnome.org/projects/gtp/teams.html)

Fortunately the GTK 2 zh_TW translation is complete in CVS so we may be able to
just copy that.
Comment 4 Ben Wu 2002-08-21 20:25:28 EDT
I just checked the zh_TW's status page of GNOME 2.0 translation.
http://developer.gnome.org/projects/gtp/status/gnome-2.0-core/zh_TW.html
I found that gtk+ is only 58.76% done. Please let me know this is not the place
where you will retrieve the updated PO file. Also please let me know if I need
to do the translation for this file because this file has effects on lots of Red
Hat 's configuration tools.
Comment 5 Havoc Pennington 2002-08-21 21:39:58 EDT
Apologies, I was generating the statistics incorrectly.

It would be good to translate GTK but we would need it by Friday or so. It's up
to Owen whether he has time to put the files in gnome-i18n/redhat-po and then
merge them into gtk again.


Comment 6 Ben Wu 2002-08-21 21:49:39 EDT
I may just do it and submit it to zh_TW's GNOME coordinator by Friday.
Comment 7 Havoc Pennington 2002-08-21 22:17:49 EDT
OK, you probably need to send the files to us as well to get them in, though, 
at this point - there won't be time for the gnome coordinator to review the
changes, and owen to make a new gtk release. of course they should also go to
the upstream coordinator so that they are still there for the next Red Hat Linux
after this one.
Comment 8 Owen Taylor 2002-08-21 22:24:14 EDT
Havoc - Why would I want to put them in gnome-i18n/redhat-po? There are
no local changes for Red Hat to the GTK+ strings.

Note that the completion status can be a bit hard to interpret
for  GTK+. There are two classes of translated strings in GTK+
which are mixed together.

 A) Strings that appear to developers, like property descriptions
    for the various controls
 B) Strings that appear to end users.

The strings in class B) are the ones that really matter; but
they aren't separated out in any way.
Comment 9 Ben Wu 2002-08-21 22:29:42 EDT
Ok, Havoc. After it is done, I will attach the file to this bug report, of
course by this Friday.
Comment 10 Havoc Pennington 2002-08-21 22:43:39 EDT
gnome-i18n/redhat-po might be useful if we don't yet have approval from the
upstream translation maintainer to commit to the main translation copy. It
should only be used if we need somewhere to keep translations and can't get
approval in time, or have custom red hat string changes.
Comment 11 Ben Wu 2002-08-22 00:11:32 EDT
Created attachment 72164 [details]
gtk+ 2.0 zh_TW.po file

Note You need to log in before you can comment on or make changes to this bug.