Bug 72221 - Gnome Keyboard shortcut: "Resize a window" doesn't work
Gnome Keyboard shortcut: "Resize a window" doesn't work
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: control-center (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-21 23:26 EDT by Josiah Royse
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 16:57:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josiah Royse 2002-08-21 23:26:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
Using the keyboard shortcut "Resize a window" displays a four-way arrow cursor,
but does not resize any windows.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run /usr/bin/gnome-keybinding-properties
2. choose a shortcut for "Resize a window" 
3. Close the program (saving)
4. try to resize a window
	

Actual Results:  Four-way arrow cursor appears, without allowing the window to
be resized.

Expected Results:  Four-way cursor to appear, and resize the the ability to
resize the window.

Additional info:
Comment 1 Havoc Pennington 2002-08-21 23:38:12 EDT
You have to press the arrow keys. (Reopen the bug if that doesn't work.)

I know it's a bit confusing, but if you think about it, the menu item would be
pretty useless if it was to resize the window with the _mouse_. ;-) It's for
resizing with the keyboard.
Comment 2 Josiah Royse 2002-08-22 16:57:16 EDT
Ok, I didn't try using the error keys when I submitted the bug originally- but
it works as you described.  

The reason I re-opened the bug is the "Move a window" shortcut works with the
mouse AND/OR the arrow keys, while the "Resize a window" shortcut ONLY works
with the arrow keys. 

Here's the bug:  
1. Use the "Resize a window" shortcut on a window
2. Press arrow key "Down" then "Left"
3. Now you can use the mouse to resize the window

Sorry- it's a bit picky, but I'm used to the way it worked in Gnome-1/Sawfish or
KDE.
Comment 3 Havoc Pennington 2002-08-22 18:54:45 EDT
For me KDE just starts a horizontal-only resize when I choose size - sort of
strange. 

Anyway I'll move the issue to http://bugzilla.gnome.org/show_bug.cgi?id=91459
and close on the Red Hat level, I mostly track metacity enhancements on gnome.org.

Note You need to log in before you can comment on or make changes to this bug.