Bug 722239 - subscription-manager cli does not show all facts
subscription-manager cli does not show all facts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Bryan Kearney
J.C. Molet
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-14 13:37 EDT by J.C. Molet
Modified: 2011-12-06 12:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system facts (11.01 KB, image/png)
2011-07-14 13:37 EDT, J.C. Molet
no flags Details

  None (edit)
Description J.C. Molet 2011-07-14 13:37:11 EDT
Created attachment 513229 [details]
system facts

Description of problem:
The subscription manager CLI does not display all facts (at least not as many as the GUI does)

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.96.4-1.git.4.f2638c9.el6.x86_64
subscription-manager-0.96.4-1.git.4.f2638c9.el6.x86_64
subscription-manager-firstboot-0.96.4-1.git.4.f2638c9.el6.x86_64
python-rhsm-0.96.7-1.git.3.f3ce5d1.el6.noarch


How reproducible:
always

Steps to Reproduce:
1.  register your subscription-manager
2.  run subscription-manager facts --list
3.  open the gui and view system facts
  
Actual results:
Some of the system facts are left out of the CLI:

[root@jmolet-vm0 facts]# subscription-manager facts --list | grep ^system
system.entitlements_valid: False

(see comparison screenshot for what the gui displays)

Expected results:
all facts shown in the CLI are also shown in the GUI and vice versa.

Additional info:
Comment 1 Bryan Kearney 2011-07-21 16:46:24 EDT
fixed in master at 9f8a6ae89409ce98e0e7daede5e4591e81a0c321.
Comment 3 J.C. Molet 2011-07-22 10:59:07 EDT
Fixed:

[root@jmolet-vm0 ~]# subscription-manager facts --list | grep ^system
system.entitlements_valid: False
system.name: jmolet-vm0.usersys.redhat.com
system.uuid: 4a83d66b-9df7-4090-b8ee-a27276349d78


subscription-manager-firstboot-0.96.4-1.git.51.be369b5.el6.x86_64
python-rhsm-0.96.7-1.git.4.ae2c338.el6.noarch
subscription-manager-gnome-0.96.4-1.git.51.be369b5.el6.x86_64
subscription-manager-0.96.4-1.git.51.be369b5.el6.x86_64


moving to VERIFIED
Comment 4 errata-xmlrpc 2011-12-06 12:22:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.