Bug 722248 - subscription-manager fact null value
subscription-manager fact null value
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: John Sefler
J.C. Molet
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-14 14:08 EDT by J.C. Molet
Modified: 2011-12-06 12:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
null value for dmi.processor.voltage is now reported as Unknown in the GUI (57.17 KB, image/png)
2011-08-08 09:44 EDT, John Sefler
no flags Details

  None (edit)
Description J.C. Molet 2011-07-14 14:08:12 EDT
Description of problem:
On some machines you are unable to determine some facts.  When read in by subscription manager, it doesn't set the values of these facts to anything.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.96.4-1.git.4.f2638c9.el6.x86_64
subscription-manager-0.96.4-1.git.4.f2638c9.el6.x86_64
subscription-manager-firstboot-0.96.4-1.git.4.f2638c9.el6.x86_64
python-rhsm-0.96.7-1.git.3.f3ce5d1.el6.noarch


Steps to Reproduce:
1. register subscription-manager on a virtual machine
2. view the system facts either by the command line or the gui
  
Actual results:
dmi.processor.voltage has no value on the CLI.

In the GUI the value field for this fact is interpreted as a NULL.  This means for that row in the table, it only contains one column, and cannot be read the same way by accessibility programs.

Expected results:
If you run dmidecode manually from the command line it displays situations like this with the value "Unknown":

[root@jmolet-vm0 facts]# dmidecode | grep -i voltage
	Voltage: Unknown
	Voltage: Unknown

Subscription manager should also set these null fields to Unknown, so that the display of these values is more consistent with dmidecode.

Additional info:
There also seems to be several other inconsistencies.  For example when dmi.memory.speed is not specified it's value is " (ns)", where dmidecode and all other not specified fields display "Not Specified".
Comment 1 Bryan Kearney 2011-07-26 14:39:51 EDT
Fixed in master at b5346938bcd75b2a7be2c7f7ac9c432a3a62d60f. All blank strings are now Unknown.
Comment 3 Shwetha Kallesh 2011-07-27 03:27:37 EDT
The blank string still appears..

RPM's used:

subscription-manager-firstboot-0.96.4-1.git.64.b534693.el6.x86_64
subscription-manager-0.96.4-1.git.64.b534693.el6.x86_64
subscription-manager-gnome-0.96.4-1.git.64.b534693.el6.x86_64

Steps to reproduce :

subscription-manager register --username=admin --password=admin --org=admin
<shwetha> The system has been registered with id: 57b50403-1e5d-4749-adb3-7ee3cdb77639 
<shwetha> [root@sachbeta ~]#  subscription-manager facts --list | grep dmi.processor.voltage
<shwetha> dmi.processor.voltage:
Comment 4 Shwetha Kallesh 2011-07-27 03:29:52 EDT
Steps to reproduce :

subscription-manager register --username=admin --password=admin --org=admin
The system has been registered with id: 57b50403-1e5d-4749-adb3-7ee3cdb77639 

subscription-manager facts --list | grep dmi.processor.voltage
dmi.processor.voltage:
Comment 6 Bryan Kearney 2011-07-29 15:02:28 EDT
Fixed in 1deab574be7c57dd95e7f8ba7bc09fb83e0d12cd in master. Left is as cosmetic so that other tools can choose to display NULL differently.
Comment 7 Shwetha Kallesh 2011-08-01 05:27:25 EDT
Please move the bug to verified..

RPMs used :
subscription-manager-firstboot-0.96.4-1.git.70.a18d152.el6.x86_64
subscription-manager-gnome-0.96.4-1.git.70.a18d152.el6.x86_64
subscription-manager-0.96.4-1.git.70.a18d152.el6.x86_64

Steps to reproduce :

subscription-manager register --username=admin --password=admin --org=admin
The system has been registered with id: 737b4a42-e167-43b6-883e-6fa3b4811a14 

subscription-manager facts --list | grep dmi.processor.voltage


dmi.processor.voltage: Unknown
Comment 8 John Sefler 2011-08-08 09:44:41 EDT
Created attachment 517219 [details]
null value for dmi.processor.voltage is now reported as Unknown in the GUI

Also verifying the GUI....
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.96.5-1.git.4.303423d.el6.x86_64

see voltage reported as "Unknown" in the screenshot
Comment 9 errata-xmlrpc 2011-12-06 12:22:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.