This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 722298 - dbreset Not Implemented for Oracle Databases
dbreset Not Implemented for Oracle Databases
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Database (Show other bugs)
4.1
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Stefan Negrea
Mike Foley
:
Depends On:
Blocks: rhq41beta
  Show dependency treegraph
 
Reported: 2011-07-14 16:51 EDT by Stefan Negrea
Modified: 2012-02-07 14:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:20:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Negrea 2011-07-14 16:51:36 EDT
Currently dbreset is not implemented for Oracle databases. This functionality is required in clear the entire database (remove all the tables and data) in one single step at build time.
Comment 1 Charles Crouch 2011-08-03 12:25:02 EDT
Marking this as urgent, since its required to get our dbupgrade integration tests running consistently on oracle
Comment 2 Stefan Negrea 2011-08-04 17:59:41 EDT
Updated dbreset code to support Oracle and PostgreSQL. 

dbreset is implemented as follows:
1) PostgreSQL - dropping the database and recreate it with rhq user as the owner.
2) Oracle - drop every single object in the user space. Temporary objects used by Oracle are not dropped.

dbreset throws an exception if the user attempts to use it with any other type of database.

The code successfully passed unit and integration testing for PostgreSQL and Oracle (10g and 11g).
Comment 3 Mike Foley 2011-08-09 16:39:52 EDT
verification criteria is passing hudson job on oracle.
Comment 4 Mike Foley 2012-02-07 14:20:50 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.