Bug 722324 - Legacy sysv init scripts should be packed seperatly or dropped
Legacy sysv init scripts should be packed seperatly or dropped
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-07-14 17:46 EDT by Jóhann B. Guðmundsson
Modified: 2011-07-15 07:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-15 07:04:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2011-07-14 17:46:40 EDT
Description of problem:

Please read the following ( Now available and official ;) ) and package dovecot according to the Fedora Packaging Guidelines.

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michal Hlavinka 2011-07-15 03:22:59 EDT
Well... this bug description is pretty useless, because it's too vague.

Anyway, 
- dovecot uses systemd for a long time now
- dovecot has systemd scripts in spec file that work and are well tested (not sure if it's exactly as packaging recommends - it was not available those days)
- dovecot uses tmpfiles.d

so from "bug description" I don't see any problem

and dovecot rpm does not contain sysv init script, so bug summary is not valid too.

Did you use correct component?
Comment 2 Jóhann B. Guðmundsson 2011-07-15 06:00:30 EDT
http://koji.fedoraproject.org/koji/rpminfo?rpmID=2544842 <--- shows /etc/rc.d/init.d/dovecot which should either be dropped or package separately according to the packagaging guidelines...

"SysV Initscripts
Packages may also provide a SysV initscript file, but are not required to do so. This format is considered legacy, but Fedora still contains init mechanisms such as upstart which do not support the systemd unit file format. If present, the SysV initscript(s) must go into an optional subpackage, so as not to confuse sysadmins. The guidelines for SysV initscripts can be found here: Packaging:SysVInitScript"
Comment 3 Michal Hlavinka 2011-07-15 07:04:12 EDT
interesting, fix is in git since May 30th, but there was no build since. Building now

Note You need to log in before you can comment on or make changes to this bug.