Bug 722334 - please report the QuantityUsed in the subscription-manager list --consumed
please report the QuantityUsed in the subscription-manager list --consumed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Devan Goodwin
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-14 18:06 EDT by John Sefler
Modified: 2011-12-06 12:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-07-14 18:06:22 EDT
Description of problem:
Now that we can subscribe with a --quantity greater than one, we need to report the QuantityUsed in the output of subscription-manager list --consumed


Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.4.f2638c9.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-onprem-62server ~]# subscription-manager subscribe --pool=8a90f8c63125f5f5013125f786430307 --quantity=5
Successfully subscribed the system to Pool 8a90f8c63125f5f5013125f786430307
[root@jsefler-onprem-62server ~]# subscription-manager list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+


ProductName:        	Awesome OS Server Bits   
ContractNumber:     	62                       
AccountNumber:      	12331131231              
SerialNumber:       	1173335069371296097      
Active:             	True                     
Begins:             	04/12/2011               
Expires:            	09/11/2012     
  



Expected results:
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+


ProductName:        	Awesome OS Server Bits   
ContractNumber:     	62                       
AccountNumber:      	12331131231              
SerialNumber:       	1173335069371296097      
QuantityUsed:           5                    <<<<<<<<<<<<<<< PLEASE ADD
Active:             	True                     
Begins:             	04/12/2011               
Expires:            	09/11/2012
Comment 1 Devan Goodwin 2011-07-15 08:40:22 EDT
Fixed in: 0405b12cc08a70707107b6c779d9f8e008b1c93d
Comment 3 spandey 2011-07-18 07:29:06 EDT
Verified using following rpm 
subscription-manager-firstboot-0.96.4-1.git.33.e182a22.el6.x86_64
subscription-manager-gnome-0.96.4-1.git.33.e182a22.el6.x86_64
subscription-manager-0.96.4-1.git.33.e182a22.el6.x86_64


ProductName:        	Awesome OS Server Bits   
ContractNumber:     	19                       
AccountNumber:      	12331131231              
SerialNumber:       	4202529573467310275      
Active:             	True                     
QuantityUsed:       	4                        
Begins:             	07/14/2011               
Expires:            	07/13/2012     


consumed list displays quantity.

Moving defect status from modified to verified.
Comment 4 errata-xmlrpc 2011-12-06 12:22:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.