Bug 72239 - xsltproc finds a loop in the docbook xsl stylesheets for tables
xsltproc finds a loop in the docbook xsl stylesheets for tables
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: docbook-style-xsl (Show other bugs)
7.3
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
http://www-uxsup.csx.cam.ac.uk/~rjd4/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-22 06:30 EDT by Bob Dowling
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 07:03:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Dowling 2002-08-22 06:30:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
A valid (at least I think it's valid) XML DocBook file (table.xml at the URL
above) causes xsltproc to fail, claiming to find a loop in the style sheets it
is processing.

I have updated the relevant packages from the 7.3 releases to the ones that ship
with the current second beta.  Exact versions are in the typescript.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Copy table.xml and Makefile from the URL given.
2.make table.fo

	

Actual Results:  System fails with error message:
 runtime error: file  /usr/share/sgml/docbook/xsl-stylesheets/fo/table.xsl line
911 element text
 xsltApplyOneTemplate: loop found ???
 try increasing xsltMaxDepth (--maxdepth)

Expected Results:  I expected a valid FO file.

Additional info:

I believe the XML file is valid because I use the emacs PSGML XML mode to create
it using it to prompt for valid elements.
Comment 1 Bob Dowling 2002-08-22 07:03:02 EDT
Scratch this.  Error lay between keyboard and seat.
(My tgroup doesn't carry the required cols attribute.  When I insert it
everything is fine)
Sorry for wasting your time.
Comment 2 Tim Waugh 2002-08-22 07:09:37 EDT
You can use 'xmllint -valid' to check validity. 
 
Guess that it works when you correct that, and closing.

Note You need to log in before you can comment on or make changes to this bug.