Bug 722401 - systemd30-1.fc16 was hanged the system
systemd30-1.fc16 was hanged the system
Status: CLOSED DUPLICATE of bug 722472
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-15 04:09 EDT by Andy Clark
Modified: 2011-07-18 07:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-18 07:53:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Clark 2011-07-15 04:09:22 EDT
Description of problem:
when you update your systemd from 29 version
to 30, after rebooting, your computer hangs 
with some message about deadlock. 

Version-Release number of selected component (if applicable):
# cat /etc/fedora-release 
Fedora release 16 (Rawhide)
# uname -a
Linux timelock.rtcomm.ru 3.0-0.rc7.git0.1.fc16.i686 #1 SMP Tue Jul 12 13:04:11 UTC 2011 i686 i686 i386 GNU/Linux
#

How reproducible:
just update your systemd{-untis,-sysv}

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:
system hang after login

Expected results:
system work properly

Additional info:
if you already update your systemd packages, 
you can do the following steps to resurrect your system :
1. boot your computer in single user mode. (in grub you must add 1
at the end of kernel string, press "Enter", press "b")
2. when booting process is done, and you get the shell, you should turn up your network interfaces. systemctl start network.service
3. download old systemd packages 
wget "ftp://ftp.muug.mb.ca/mirror/fedora/linux/development/rawhide/i386/os/Packages/systemd-29-1.fc16.i686.rpm"
wget "ftp://ftp.muug.mb.ca/pub/fedora/linux/development/rawhide/i386/os/Packages/systemd-sysv-29-1.fc16.i686.rpm"
wget "ftp://ftp.muug.mb.ca/pub/fedora/linux/development/rawhide/i386/os/Packages/systemd-units-29-1.fc16.i686.rpm"
4. install old packages 
rpm -Uvh --oldpackage systemd*
5. reboot

Your system should booting as usual

if you need additional information, please let me know.
Comment 1 Michal Schmidt 2011-07-15 07:45:57 EDT
(In reply to comment #0)
> Description of problem:
> when you update your systemd from 29 version
> to 30, after rebooting, your computer hangs 
> with some message about deadlock. 

Could you please write the exact message or take a picture of it?
Comment 2 Andy Clark 2011-07-15 14:13:59 EDT
I'll try, but this computer is my workstation. Leave this question until Monday, if you don't mind.
Comment 3 Andy Clark 2011-07-18 01:36:39 EDT
As i promised before, here is the pictures:

1. http://rghost.net/14918961/image.png
2. http://rghost.net/14918981/image.png

With new kernel 

# uname -a
Linux timelock.rtcomm.ru 3.0-0.rc7.git3.1.fc16.i686 #1 SMP Fri Jul 15 23:15:00 UTC 2011 i686 i686 i386 GNU/Linux
#

problem still exists.
Comment 4 Andy Clark 2011-07-18 02:21:14 EDT
As i promised before, here is the pictures:

1. http://rghost.net/14918961/image.png
2. http://rghost.net/14918981/image.png

With new kernel 

# uname -a
Linux timelock.rtcomm.ru 3.0-0.rc7.git3.1.fc16.i686 #1 SMP Fri Jul 15 23:15:00 UTC 2011 i686 i686 i386 GNU/Linux
#

problem still exists.
Comment 5 Michal Schmidt 2011-07-18 07:53:18 EDT
It's a kernel bug that systemd-logind somehow triggers.

*** This bug has been marked as a duplicate of bug 722472 ***

Note You need to log in before you can comment on or make changes to this bug.