Bug 722497 - lighttpd's init scripts are broken
Summary: lighttpd's init scripts are broken
Keywords:
Status: CLOSED DUPLICATE of bug 656612
Alias: None
Product: Fedora
Classification: Fedora
Component: lighttpd
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-15 14:38 UTC by redhat-bugzilla
Modified: 2011-07-25 08:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-25 08:55:12 UTC
Type: ---


Attachments (Terms of Use)

Description redhat-bugzilla 2011-07-15 14:38:10 UTC
Description of problem:
There are 2 problems, first is that the init.d script for lighttpd is written to use systemd but there is no actual systemd service file, so systemd trys to run the /etc/init.d/lighttpd script which obviously makes the whole thing fail

The second problem i guess is related to this same thing but, even to start lighttpd manually, you must first create /var/run/lighttpd folder and chown it to lighttpd user

Version-Release number of selected component (if applicable):
lighttpd-1.4.26-4.fc15.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install lighttpd
2. try to start it up with init.d scripts or systemctl
  
Actual results:
It won't start

Expected results:
It Starts

Comment 1 Matthias Saou 2011-07-20 12:37:01 UTC
Can you please try the lighttpd-1.4.28-3.fc15 package from updates-testing? I think that all of your problems should be fixed there. The /var/run/ directory problem has already been reported as bug #656612.

Comment 2 redhat-bugzilla 2011-07-20 12:50:02 UTC
this testing package works great :) thanks

Comment 3 Matthias Saou 2011-07-25 08:55:12 UTC
Thanks for confirming. The update is now pending to be pushed to stable.

*** This bug has been marked as a duplicate of bug 656612 ***


Note You need to log in before you can comment on or make changes to this bug.