Bug 72253 - ifdown of Token Ring interface
ifdown of Token Ring interface
Status: CLOSED DUPLICATE of bug 71800
Product: Red Hat Public Beta
Classification: Retired
Component: initscripts (Show other bugs)
null
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-22 09:09 EDT by Rafael Ugalde
Modified: 2014-03-16 22:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 18:09:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael Ugalde 2002-08-22 09:09:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
when i execute ifdown of token ring interface the script goes into a loop

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.ifdown tr0
2.
3.
	

Actual Results:  the script goes into a loop.

Additional info:

This is the execution of ifdown tr0 -------->

 . /etc/init.d/functions
++ TEXTDOMAIN=initscripts
++ TEXTDOMAINDIR=/etc/locale
++ umask 022
++ PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
++ export PATH
++ '[' -z '' ']'
++ COLUMNS=80
++ '[' -z '' ']'
+++ /sbin/consoletype
++ CONSOLETYPE=pty
++ '[' -f /etc/sysconfig/i18n -a -z '' ']'
++ . /etc/sysconfig/i18n
+++ LANG=es_ES.UTF-8
+++ SUPPORTED=es_ES.UTF-8:es_ES:es
+++ SYSFONT=LatArCyrHeb-16
++ '[' pty '!=' pty ']'
++ export LANG
++ '[' -z '' ']'
++ '[' -f /etc/sysconfig/init ']'
++ . /etc/sysconfig/init
+++ BOOTUP=color
+++ RES_COL=60
+++ MOVE_TO_COL=echo -en \033[60G
+++ SETCOLOR_SUCCESS=echo -en \033[0;32m
+++ SETCOLOR_FAILURE=echo -en \033[0;31m
+++ SETCOLOR_WARNING=echo -en \033[0;33m
+++ SETCOLOR_NORMAL=echo -en \033[0;39m
+++ LOGLEVEL=3
+++ PROMPT=yes
++ '[' pty = serial ']'
++ '[' color '!=' verbose ']'
++ INITLOG_ARGS=-q
+ cd /etc/sysconfig/network-scripts
+ . network-functions
++ PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
++ export PATH
+ CONFIG=tr0
+ '[' -z tr0 ']'
+ need_config tr0
+ '[' -f tr0 ']'
+ CONFIG=../networking/default/tr0
+ '[' -f ../networking/default/tr0 ']'
+ CONFIG=../networking/default/ifcfg-tr0
+ '[' -f ../networking/default/ifcfg-tr0 ']'
+ CONFIG=ifcfg-tr0
+ '[' -f ifcfg-tr0 ']'
+ '[' 0 '!=' 0 ']'
+ source_config
++ basename ifcfg-tr0
++ sed 's/^ifcfg-//g'
+ DEVNAME=tr0
+ basename ifcfg-tr0
+ grep -q '[^g]-'
+ . ifcfg-tr0
++ USERCTL=no
++ PEERDNS=no
++ GATEWAY=154.200.10.3
++ TYPE=Token Ring
++ DEVICE=tr0
++ HWADDR=08:00:5a:d2:42:af
++ BOOTPROTO=none
++ NETMASK=255.255.0.0
++ ONBOOT=yes
++ IPADDR=154.200.10.5
++ NETWORK=154.200.0.0
++ BROADCAST=154.200.255.255
+ '[' -x /sbin/ifdown-pre-local ']'
++ echo tr0
++ sed 's/[0-9]*$//'
+ DEVICETYPE=tr
+ '[' -z '' ']'
++ echo tr0
++ sed 's/:.*//g'
+ REALDEVICE=tr0
+ OTHERSCRIPT=/etc/sysconfig/network-scripts/ifdown-tr
+ '[' -x /etc/sysconfig/network-scripts/ifdown-tr ']'
+ . /etc/sysconfig/network
++ NETWORKING=yes
++ HOSTNAME=srvlnx01
+ check_device_down tr0
+ echo tr0
+ grep -q :
+ LC_ALL=C
+ ip -o link ls dev tr0
+ grep -q ,UP
+ return 1
+ '[' -n 08:00:5a:d2:42:af ']'
++ LC_ALL=
++ LANG=
++ ip -o link show tr0
++ sed 's/.*link\/ether \([[:alnum:]:]*\).*/\1/'
+ FOUNDMACADDR=2: tr0: <BROADCAST,MULTICAST,UP> mtu 2000 qdisc pfifo_fast qlen 
100\    link/tr 08:00:5a:d2:42:af brd ff:ff:ff:ff:ff:ff
+ '[' '2: tr0: <BROADCAST,MULTICAST,UP> mtu 2000 qdisc pfifo_fast qlen 100\    
link/tr 08:00:5a:d2:42:af brd ff:ff:ff:ff:ff:ff' '!=' 08:00:5a:d2:42:af ']'
++ fgrep -l HWADDR=08:00:5a:d2:42:af /etc/sysconfig/network-scripts/ifcfg-
lo /etc/sysconfig/network-scripts/ifcfg-tr0
+ NEWCONFIG=/etc/sysconfig/network-scripts/ifcfg-tr0
+ '[' -n /etc/sysconfig/network-scripts/ifcfg-tr0 ']'
+ exec /sbin/ifdown /etc/sysconfig/network-scripts/ifcfg-tr0

-------------------------------------------------------------------

I think it is searching for one ether interface to obtain HWADDR and it is not 
working because the result of ip -o link show tr0 is link/tr not link/ether.
Comment 1 Bill Nottingham 2002-08-27 18:09:53 EDT
Should be fixed in 6.92-1.
Comment 2 Jay Turner 2002-09-03 12:14:56 EDT

*** This bug has been marked as a duplicate of 71800 ***

Note You need to log in before you can comment on or make changes to this bug.