Bug 72255 - [patch] Error in module SiS_driver.so
[patch] Error in module SiS_driver.so
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
David Lawrence
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-22 09:18 EDT by Johan Hendriks
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-03 23:46:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of 'strace /usr/X11R6/lib/xscreensaver/atlantis' with XFree86-4.2.0-67.6, kernel-2.4.18-12.4 (47.41 KB, text/plain)
2002-08-28 04:05 EDT, Tim Waugh
no flags Details
This patch fixes it for me. (855 bytes, patch)
2002-08-28 04:52 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Johan Hendriks 2002-08-22 09:18:21 EDT
This is my /etc/sysconfig/hwconf file
>
>class: VIDEO
>bus: PCI
>detached: 0
>driver: Card:SiS 6326
>desc: "Silicon Integrated Systems [SiS]|86C326 5598/6326"
>vendorId: 1039
>deviceId: 6326
>subVendorId: 1039
>subDeviceId: 6326
>pciType: 1
>-
>
>This is the error i get
>
>SiS driver: out of video memory
>fatal error in sis_driver.so
>xscreenserver 15:46:22 0: child pid 17878
>(glsnake) exited abnormally (code -1).
Comment 1 Tim Waugh 2002-08-27 05:16:16 EDT
I see this too.
Comment 2 Mike A. Harris 2002-08-27 15:33:39 EDT
How about telling me exactly what XFree86 RPM packages are installed.
Comment 3 Tim Waugh 2002-08-27 18:25:47 EDT
For instance, XFree86-4.2.0-67.  But I've seen this for a while.
Comment 4 Mike A. Harris 2002-08-27 21:47:34 EDT
twaugh)  sorry... I was asking  johan@double-l.nl what he had installed..
I should have been more clear perhaps.

This bug report currently contains no useful information to be able
to do anything about the problem or debug it.  Someone needs to provide
useful and detailed information, including the usual logs/configs, etc.
or I can't really even look into it at all.

I also have no SiS hardware to even try to reproduce.  So the more
info supplied, the better chances of me seeing something in the driver
code that might be obvious.

A backtrace or gdb debugging session would also be nice if possible.

ftp://people.redhat.com/mharris/gdb-xfree86
Comment 5 Mike A. Harris 2002-08-27 21:55:13 EDT
Additionally... this could be the problem Alan is seeing on SiS.
I've put a few SiS patches in my latest builds I forgot to mention.
Without someone able to test them though, I can't do much.
Comment 6 Tim Waugh 2002-08-28 04:05:44 EDT
Created attachment 73464 [details]
output of 'strace /usr/X11R6/lib/xscreensaver/atlantis' with XFree86-4.2.0-67.6, kernel-2.4.18-12.4
Comment 7 Tim Waugh 2002-08-28 04:07:21 EDT
Since this is coming from a module I don't really see how to get a gdb trace.  
Let me know what else you want.
Comment 8 Tim Waugh 2002-08-28 04:15:41 EDT
Okay, this is actually a redhat-config-xfree86 problem.
Comment 9 Tim Waugh 2002-08-28 04:18:50 EDT
To fix this I had to start redhat-config-xfree86 (System Settings->Display), 
and click on the 'Advanced' tab.  The 'Enable Hardware 3D Acceleration' 
checkbox was greyed out, but the checkbox was ticked.  I clicked on 
'Configure' in the video card section, changed the driver to 'mga', and 
clicked OK, so that the checkbox was sensitive.  Then I unchecked it, and 
changed the driver back to 'sis'. 
 
Now it works.  So redhat-config-xfree86 should uncheck the checkbox as well as 
desensitise it.
Comment 10 Tim Waugh 2002-08-28 04:52:02 EDT
Created attachment 73484 [details]
This patch fixes it for me.
Comment 11 Alexander Larsson 2002-08-28 05:34:02 EDT
Patch applied in r-c-x 0.6.5.
Comment 12 Jay Turner 2002-09-03 23:45:47 EDT
Can someone with the SiS problems confirm that this new package fixes things?
Comment 13 Tim Waugh 2002-09-04 04:15:24 EDT
Works for me.

Note You need to log in before you can comment on or make changes to this bug.