Red Hat Bugzilla – Bug 72257
php 4.2.2-9 requires dependancy on glibc 2.2.90-23 at least: GLIBC_2.3 version needed in libc.so.6
Last modified: 2007-04-18 12:45:48 EDT
Description of Problem:
php-4.2.2-9 which is currently in rawhide, needs a dependancy on the current glibc-2.2.90-23: it
needs the version GLIBC_2.3 which is not accessible in for example glibc-2.2.90-15
The exact error message is:
[root@delirium conf]# sudo /etc/rc.d/init.d/httpd start
Starting httpd: Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp4.so: symbol
realpath, version GLIBC_2.3 not defined in file libc.so.6 with link time reference
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. Install this php-4.2.2-9, without upgrading glibc
2. try to restart httpd
no httpd running
a running httpd of course :-)
Umm I'm going to hold off on this one a few days. Theres a naming debate going
on which I'd need to know the answer to first.
This is fixed in php-4.2.2-11, which has a requirement for libc.so.6(GLIBC_2.3).
Thanks for the report.