Bug 722629 - Provide native systemd unit file
Provide native systemd unit file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bootparamd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukáš Nykrýn
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-07-15 19:33 EDT by Jóhann B. Guðmundsson
Modified: 2011-09-13 02:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: bootparamd-0.17-33.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-05 12:03:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Native systemd unit file for bootparamd (245 bytes, text/plain)
2011-07-15 19:37 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-07-15 19:33:30 EDT
Description of problem:

https://fedoraproject.org/wiki/Features/SysVtoSystemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-07-15 19:37:59 EDT
Created attachment 513453 [details]
Native systemd unit file for bootparamd

Note this is untested hence you might need to tweak the Type= type a bit as in if this does not work try 

[Service]
Type=forking
....
or

[Service]
Type=oneshot
RemainAfterExit=yes
....

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 2 Fedora Admin XMLRPC Client 2011-08-08 09:49:28 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Jóhann B. Guðmundsson 2011-08-22 14:28:04 EDT
ping?
Comment 4 Lukáš Nykrýn 2011-09-05 12:03:33 EDT
I have used your unit file and changed type to forking. Also I have altered spec file accordingly.
Comment 5 Jóhann B. Guðmundsson 2011-09-05 12:08:42 EDT
Note that it would be good to get this into F16 since there is still a window to do that.. ( until we release beta )
Comment 6 Fedora Update System 2011-09-06 04:01:16 EDT
bootparamd-0.17-33.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/bootparamd-0.17-33.fc16
Comment 7 Fedora Update System 2011-09-13 02:10:06 EDT
bootparamd-0.17-33.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.