Bug 72272 - up2date does not do dependency check
up2date does not do dependency check
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-22 13:16 EDT by petrosyan
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 14:11:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2002-08-22 13:16:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
up2date does not do dependency check while installing gnomemeeting.

Version-Release number of selected component (if applicable):
2.9.46-1

How reproducible:
Always

Steps to Reproduce:
1.make sure you don't have gnomemeeting, pwlib and openh323 rpms installed. if
you do remove them by rpm -e openh323 pwlib gnomemeeting
2.install gnomemeeting via "up2date gnomemeeting"
run gnomemeeting and see that it does not even start because the necessary pwlib
and openh323 libs were not installed
	

Actual Results:  gnomemeeting does not start because it cannot load the shared
libraries

Expected Results:  up2date should have resolved the dependencies and installed
pwlib and openh323

Additional info:

when I downloaded gnomemeeting package and wanted to install it from the 
command line using rpm -i gnomemeeting-0.93.1-3.i386.rpm
it complained about unresolved dependencies: pwlib and openh323
so I think that this is not an rpm issue but it is an up2date issue.
the same kind of story happened with up2dating octave. bug # 72026
Comment 1 Adrian Likins 2002-08-22 14:11:14 EDT
Sounds like the same bug as bug # 72026

To be more specific, the bug itself is in rpm-python. The
rpm commandline works correctly, but the part of rpm-python
that is used to solve deps is busted. 

Comment 2 petrosyan 2002-12-12 13:44:30 EST
fixed in RHL 8.0

Note You need to log in before you can comment on or make changes to this bug.