Bug 72275 - text scrolled to left makes selections unreadable
text scrolled to left makes selections unreadable
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gtk2 (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-22 13:28 EDT by Mike Gerdts
Modified: 2013-04-02 00:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 14:36:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sceenshot of fubarred window (50.56 KB, image/png)
2002-08-22 13:30 EDT, Mike Gerdts
no flags Details
test case for treeview bug (981 bytes, text/plain)
2002-08-23 05:30 EDT, Alexander Larsson
no flags Details
fix scroll_to (14.03 KB, patch)
2002-08-25 18:02 EDT, Jonathan Blandford
no flags Details | Diff

  None (edit)
Description Mike Gerdts 2002-08-22 13:28:08 EDT
As I was trying to change my X settings, I somehow managed to get into a state
where the monitor manufacturer list was scrolled to the left but no horizontal
scrollbar was available.  See screenshot.

As for reproducing it... 

In the display settings window, select advanced.

click configure in the top pane

Select a monitor that has a descriptive name that is too long to fit in the left
pane.

Select OK  The monitor settings window will close.

Click configure in the display settings window
Comment 1 Mike Gerdts 2002-08-22 13:30:20 EDT
Created attachment 72284 [details]
sceenshot of fubarred window
Comment 2 Alexander Larsson 2002-08-23 04:58:54 EDT
I fixed this somewhat by doing:

-        tree_view.scroll_to_cell(path, self.col, TRUE, 0.5, 0.5)
+        tree_view.scroll_to_cell(path, self.col, TRUE, 0.5, 0.0)

But there is still a bug in the treeview where doing this repeatedly scrolls the
tree horizontally a little bit each time. jrb, have you looked into this? (It's
the same bug i had before in the videocard list.)
Comment 3 Alexander Larsson 2002-08-23 05:29:48 EDT
jrb, i'm assigning this to you, because it really seems to be a treeview bug.
I'm attaching a small standalone testcase.
Comment 4 Alexander Larsson 2002-08-23 05:30:51 EDT
Created attachment 72524 [details]
test case for treeview bug
Comment 5 Alexander Larsson 2002-08-23 05:34:09 EDT
Note: If you remove the "gazonk" part of the tree it will still be broken, but
only scroll one pixel each time you click the button.
Comment 6 Jonathan Blandford 2002-08-25 18:01:44 EDT
Thanks for the test case, alex.  Here's a fix for GTK+ for it.
Comment 7 Jonathan Blandford 2002-08-25 18:02:33 EDT
Created attachment 72868 [details]
fix scroll_to
Comment 8 Alexander Larsson 2002-08-26 14:24:02 EDT
Uhm? That's some keyboard accel patch.
Comment 9 Jonathan Blandford 2002-08-26 14:36:10 EDT
Argh!  I selected the wrong patch!  Teaches me to do a cvs diff > /tmp/foo[1-5].

Anyway, I just built a new GTK+ that should (TM) fix it.
Comment 10 Jonathan Blandford 2002-09-12 16:55:57 EDT
This was fixed, and put in GNOME CVS.

Note You need to log in before you can comment on or make changes to this bug.