Bug 72285 - sound config broken with sound card and audio USB
sound config broken with sound card and audio USB
Status: CLOSED DUPLICATE of bug 75015
Product: Red Hat Public Beta
Classification: Retired
Component: kudzu (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 2002-08-22 14:44 EDT by Paul Jenner
Modified: 2014-03-16 22:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-22 15:53:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Paul Jenner 2002-08-22 14:44:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
This may not be redhat-config-soundcard but its a good place to start :-)

I have a soundcard (Creative SB Live! - module emu10k1) and a USB audio device
(Philips camera - pwc module). redhat-config-soundcard both detected my emu10k
as part of firstboot and when run manually afterward. However, on both occasions
the "Play test sound" failed to play any sound. In addition, xmms with the OSS
plugin just sped through ogg files too quickly with no sound output.

/etc/modules.conf had been configured with two sound devices -  sound-slot-0
pointed at the correct emu10k1 module and sound-slot-1 pointed at the "audio"
module. Both modules were loaded when I checked in normal operation.

When I "rmmod"'d the "audio" module and removed the sound-slot-1 config lines
from /etc/modules.conf, sound began to work again immediately. The test sound
played in redhat-config-soundcard and xmms played ogg files perfectly.

It appears that redhat-config-soundcard or other config program had set-up the
USB camera as sound-slot-1 device and this was being used as preferential output

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try (would require re-install)

Steps to Reproduce:
1. Installed on my system with noted hardware
2. Symptoms occurred

Additional info:

I have reports of this same thing occurring on Red Hat 7.3 with a soundcard and
USB camera with audio installed but I can't verify myself. Thus this may be a
known issue.
Comment 1 Brent Fox 2002-08-22 15:53:20 EDT
Kudzu is actually doing the probing and configuring of modules.conf, so I'm
changing the component to that.  One workaround might be to unplug the USB audio
device during installation.
Comment 2 Paul Jenner 2002-10-03 14:39:46 EDT
Re-tried with Red Hat 8.0, got a clearer debug and re-bugged as id 75015.

*** This bug has been marked as a duplicate of 75015 ***

Note You need to log in before you can comment on or make changes to this bug.