Bug 72286 - rhn screen nonfunctional
rhn screen nonfunctional
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: firstboot (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-22 14:45 EDT by Jim Wright
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:29:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Wright 2002-08-22 14:45:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
with "yes" selected in the rhn screen, the system doesn't appear to do anything
when I press "forward".  there are no messages on VC1.

selecting "no" allows me to proceed.  I have a sneaking suspicion that this is
intended behavior at this time.  but just in case... bugzilla is my friend.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.haven't tried

Additional info:
Comment 1 Brent Fox 2002-08-22 15:45:17 EDT
Do you have up2date installed?  The up2date application should have launched. 
If it's not installed, then I must have a missing dependency.
Comment 2 Jim Wright 2002-08-22 15:51:20 EDT
this was an "everything" install, so yes up2date-2.9.46-1 is installed.
Comment 3 Brent Fox 2002-08-22 16:01:13 EDT
Very strange.  This works fine for me.  Can you try running up2date from the
command line?  Perhaps it is crashing for some reason...
Comment 4 Jim Wright 2002-08-22 16:09:37 EDT
"up2date", "/usr/sbin/up2date", or "rhn_register"?

and should I run at 640x480x24 (which is the environment that firstboot
encountered due to my bad) or at 1280x1024x16 (which is what I subsequently
corrected it to).
Comment 5 Brent Fox 2002-08-22 17:25:51 EDT
Just run up2date at whatever resolution you're at.  rhn_register has been merged
into up2date, so they're actually the same program now.
Comment 6 Jim Wright 2002-08-22 18:59:39 EDT
running it now, all going well.  during or after the calculation of the
installed packages, the following message was sent to the x terminal window in
which I started up2date:


TypeError: hide() takes no arguments (1 given)


upon connecting to the remote rhn server to upload info on my system, got the
following message on the terminal:


(up2date:28425): GLib-GObject-WARNING **: gsignal.c:775: no emission of signal
"prepare" to stop for instance '0x85a3c78'
TypeError: hide() takes no arguments (1 given)


and then the following dialog (which I won't type in completely) came up:


Error Message:
  Service not enabled for server profile: "rh80rc1"
Error Class Code: 31
[...etc...]

note that the word wrapping in this dialog is just a bit wrong.  it appears to
be writing a single line at a time so that blanks can be inserted at the
beginning to show an indented effect, but in most lines one or two words wrap
and the overall effect is pretty bad looking.  if I resize the dialog wider, it
just centers the poorly formatted text instead of fixing the bad wrapping.


I just went to rhn.redhat.com and changed the entitlement to be for this
machine.  (actually same machine, but upgrade from milan to null.)  reran
up2date, but this time I'm getting "Free service limited du to high load".  note
that this error dialog also has the poorly wrapped text syndrome.


I'll try again later, but it looks like up2date is working.  do you want any of
the above issues as separate bug reports against up2date?
Comment 7 Jim Wright 2002-08-22 19:11:12 EDT
hmmm, looking at rhn.redhat.com, it shows this system entered, and I changed it
to be entitled, but it also lists it as having no packages installed.  (and thus
needing no updates.)  seems like the "service not enabled" error caused this. 
I'll keep trying to get through, and if it doesn't clear up I'll open a new
report on that aspect of this.
Comment 8 Brent Fox 2002-08-28 17:01:01 EDT
I am unable to reproduce this problem on any of my systems.  Jay, have you been
able to reproduce this?
Comment 9 Brent Fox 2003-05-25 10:29:26 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.

Note You need to log in before you can comment on or make changes to this bug.