Bug 722862 - [doc]confusion of iface-mac & iface-name in man page
Summary: [doc]confusion of iface-mac & iface-name in man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Peter Krempa
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-18 09:43 UTC by zhe peng
Modified: 2011-12-06 11:16 UTC (History)
7 users (show)

Fixed In Version: libvirt-0.9.4-rc1-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Virsh man page contained duplicate documentation for "iface-name", lack of documentation for "iface-mac" and inconsistent option names with "virsh help". Consequence: Confusion while reading the man page. Lack of information about the "iface-mac" command. Fix: Man page was fixed to contain correct descriptions. Result: Commands in question are documented.
Clone Of:
Environment:
Last Closed: 2011-12-06 11:16:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description zhe peng 2011-07-18 09:43:11 UTC
Description of problem:
confusion of iface-mac & iface-name in man page

Version-Release number of selected component (if applicable):
libvirt-0.9.3-5.el6.x86_64

How reproducible:
always

#man virsh
  
Actual results:
...
iface-name iface-MAC
           Convert a host interface MAC to interface name, if the iface-MAC is unique among the host’s interfaces.

iface-name iface-MAC
           Convert a host interface name to MAC address.
...
Expected results:
...
iface-name iface-MAC
           Convert a host interface MAC to interface name, if the iface-MAC is unique among the host’s interfaces.

iface-mac iface-NAME
           Convert a host interface name to MAC address.

...
Additional info:
using virsh command:
#virsh iface-name 00:1b:21:39:8b:18
eth0
#virsh iface-mac eth0
00:1b:21:39:8b:18

Comment 1 Eric Blake 2011-07-18 20:05:06 UTC
Upstream patch under discussion:
https://www.redhat.com/archives/libvir-list/2011-July/msg01084.html

Comment 2 Osier Yang 2011-07-19 03:22:45 UTC
commit dde5681356dc3f5a790b8c1a5763c8efa0d398c7
Author: Osier Yang <jyang@redhat.com>
Date:   Tue Jul 19 11:19:25 2011 +0800

    doc: Correct documents for iface commands
    
    The problems:
        * Duplicate documents for "iface-name"
        * Lacks of document for "iface-mac"
        * Inconsistent option names with virsh help strings.

Patch pushed to upstream, move to POST.

Comment 5 Huang Wenlong 2011-08-08 01:51:04 UTC
verify this bug with

#rpm -q libvirt 
libvirt-0.9.4-1.el6.x86_64

#man virsh 
...
iface-name interface
           Convert a host interface MAC to interface name, if the MAC address is unique among the host’s
           interfaces.

           interface specifies the interface MAC address.

iface-mac interface
           Convert a host interface name to MAC address.

           interface specifies the interface name.

...

Comment 6 Peter Krempa 2011-11-11 10:33:54 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:
Virsh man page contained duplicate documentation for "iface-name", lack of documentation for "iface-mac" and inconsistent option names with "virsh help".

Consequence:
Confusion while reading the man page. Lack of information about the "iface-mac" command.

Fix:
Man page was fixed to contain correct descriptions.

Result:
Commands in question are documented.

Comment 7 errata-xmlrpc 2011-12-06 11:16:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.