Bug 722889 - GUI : Not able to select subscription quantity from gui .
GUI : Not able to select subscription quantity from gui .
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-18 07:41 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 08:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error screenshot (139.85 KB, image/png)
2011-07-21 06:42 EDT, spandey
no flags Details

  None (edit)
Description spandey 2011-07-18 07:41:52 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
3/3

Prerequisites:
Rhel 6.2 with latest subscription-manager 

python-rhsm-0.96.7-1.el6.noarch

subscription-manager-firstboot-0.96.4-1.git.33.e182a22.el6.x86_64

subscription-manager-gnome-0.96.4-1.git.33.e182a22.el6.x86_64

subscription-manager-0.96.4-1.git.33.e182a22.el6.x86_64


Steps to repro :
Launch subscription manager gui.
Select “Awesome OS Server Bundled(2 sockets,Standard Support)
Press subscribe button 
Quantity selection should enabled at contract selection box .

Expected Result : 
Not able to select subscription quantity .

Working fine via cli
Comment 2 John Sefler 2011-07-19 13:12:06 EDT
The quantity should only be settable for pools whose product possesses a "multi-entitlement" attribute set to "yes"/1.  Within the current TESTDATA the "Awesome OS Basic Server (multi-entitlement)" pool has this attribute.  Try again with that pool.

See related bug 723248 and bug 722975.
I believe this bug should be closed as not a bug
Comment 3 spandey 2011-07-21 06:41:29 EDT
John i can subscribe quantity using cli but not from gui for same subscription .
As per your suggestion i tested it  using  Awesome OS Basic Server.

got the same issue .
Find the attached screenshot (error.pnq).
Comment 4 spandey 2011-07-21 06:42:06 EDT
Created attachment 514178 [details]
error screenshot
Comment 5 spandey 2011-07-21 08:03:09 EDT
John please ignore my above comment.
Comment 6 spandey 2011-07-21 08:12:11 EDT
Tested with John suggestion 
Working fine 
Resolving defect as "Not a bug"

Note You need to log in before you can comment on or make changes to this bug.