Bug 723336 - regression - traceback thrown in /usr/libexec/rhsmd
regression - traceback thrown in /usr/libexec/rhsmd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-19 15:41 EDT by John Sefler
Modified: 2011-12-06 12:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-07-19 15:41:41 EDT
Description of problem:

This appears to be a recent regression in /usr/libexec/rhsmd.  It is throwing a traceback....

[root@jsefler-onprem-62server ~]# /usr/libexec/rhsmd -s -d
Traceback (most recent call last):
  File "/usr/libexec/rhsmd", line 181, in <module>
    main()
  File "/usr/libexec/rhsmd", line 152, in main
    status = check_status()
  File "/usr/libexec/rhsmd", line 68, in check_status
    sorter = certlib.CertSorter(certlib.ProductDirectory(),
AttributeError: 'module' object has no attribute 'CertSorter'



Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.40.158de0a.el6.x86_64
[root@jsefler-onprem-62server ~]# rpm -q python-rhsm
python-rhsm-0.96.7-1.git.3.f3ce5d1.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-onprem-62server ~]# subscription-manager facts --list | grep entitlements_valid
system.entitlements_valid: False
[root@jsefler-onprem-62server ~]# /usr/libexec/rhsmd -s -d
Traceback (most recent call last):
  File "/usr/libexec/rhsmd", line 181, in <module>
    main()
  File "/usr/libexec/rhsmd", line 152, in main
    status = check_status()
  File "/usr/libexec/rhsmd", line 68, in check_status
    sorter = certlib.CertSorter(certlib.ProductDirectory(),
AttributeError: 'module' object has no attribute 'CertSorter'

Expected results:
System has one or more certificates that are not valid




[root@jsefler-onprem-62server ~]# mkdir /tmp/empty
[root@jsefler-onprem-62server ~]# sed -i s/productCertDir.*/productCertDir=\\/tmp\\/empty/g /etc/rhsm/rhsm.conf
[root@jsefler-onprem-62server ~]# subscription-manager facts --list | grep entitlements_valid
system.entitlements_valid: True
[root@jsefler-onprem-62server ~]# /usr/libexec/rhsmd -s -d
Traceback (most recent call last):
  File "/usr/libexec/rhsmd", line 181, in <module>
    main()
  File "/usr/libexec/rhsmd", line 152, in main
    status = check_status()
  File "/usr/libexec/rhsmd", line 68, in check_status
    sorter = certlib.CertSorter(certlib.ProductDirectory(),
AttributeError: 'module' object has no attribute 'CertSorter'

Expected results:
System entitlements appear valid


Additional info:
Comment 1 Bryan Kearney 2011-07-22 11:38:47 EDT
Fixed in master at 2f732a0184bc51d02cb4c9bae51ec150b4f68922
Comment 3 John Sefler 2011-07-25 17:13:15 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.54.5de26be.el6.x86_64


[root@jsefler-onprem-62server ~]# subscription-manager facts --list | grep entitlements_valid
system.entitlements_valid: False
[root@jsefler-onprem-62server ~]# /usr/libexec/rhsmd -s -d
System has one or more certificates that are not valid
['100000000000006', '1144', '100000000000011', '100000000000010', '100000000000013', '100000000000012', '100000000000015', '27060', '37090', '1', '37069', '37068', '37080', '37065', '37067', '37060', '37062', '100000000000060', '100000000000007', '100000000000004', '100000000000005', '100000000000002', '100000000000003', '100000000000000', '100000000000001', '100000000000020', '100000000000022', '100000000000009', '100000000000008', '917571', '37070']
[]


[root@jsefler-onprem-62server ~]# mkdir /tmp/empty
[root@jsefler-onprem-62server ~]# sed -i s/productCertDir.*/productCertDir=\\/tmp\\/empty/g /etc/rhsm/rhsm.conf
[root@jsefler-onprem-62server ~]# subscription-manager facts --list | grep entitlements_valid
system.entitlements_valid: True
[root@jsefler-onprem-62server ~]# /usr/libexec/rhsmd -s -d
System entitlements appear valid


moving to VERIFIED
Comment 4 errata-xmlrpc 2011-12-06 12:22:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.